summaryrefslogtreecommitdiff
path: root/app-text/libmwaw/libmwaw-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/libmwaw/libmwaw-9999.ebuild')
-rw-r--r--app-text/libmwaw/libmwaw-9999.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/app-text/libmwaw/libmwaw-9999.ebuild b/app-text/libmwaw/libmwaw-9999.ebuild
index bd259959df53..f0bf404e1fb2 100644
--- a/app-text/libmwaw/libmwaw-9999.ebuild
+++ b/app-text/libmwaw/libmwaw-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-if [[ ${PV} = 9999 ]]; then
+if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://git.code.sf.net/p/libmwaw/libmwaw"
inherit autotools git-r3
else
@@ -18,27 +18,26 @@ LICENSE="LGPL-2.1"
SLOT="0"
IUSE="doc tools"
-BDEPEND="
- sys-devel/libtool
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
-"
DEPEND="
dev-libs/librevenge
sys-libs/zlib
"
RDEPEND="${DEPEND}"
+BDEPEND="
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
src_prepare() {
default
- [[ ${PV} == 9999 ]] && eautoreconf
+ [[ ${PV} == *9999* ]] && eautoreconf
}
src_configure() {
# zip is hard enabled as the zlib is dep on the rdeps anyway
local myeconfargs=(
--enable-zip
- --disable-static
--disable-werror
$(use_with doc docs)
$(use_enable tools)