summaryrefslogtreecommitdiff
path: root/app-text/lesspipe
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/lesspipe')
-rw-r--r--app-text/lesspipe/Manifest1
-rw-r--r--app-text/lesspipe/lesspipe-1.83-r1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-text/lesspipe/Manifest b/app-text/lesspipe/Manifest
index ea9bbfb017d6..e8ae572deaf6 100644
--- a/app-text/lesspipe/Manifest
+++ b/app-text/lesspipe/Manifest
@@ -1,3 +1,4 @@
DIST lesspipe-1.83.tar.gz 115129 BLAKE2B 24d9e4a226537a44c01c316528e085c6d2d7889b2ae5166d70b85e12c5f0b34e825e039a70071d7e75947e1c63d527decb21973631e910de42c75ec3ee17436c SHA512 c6418ac2bfc2dee9d32d56b0ea4a94954b1431db54fef8b67a9cf7d961cf4a23d87b2f41b2a4560d2333029c6d4ed5c6f399cb635f857bd43f1603993b5cb55d
+EBUILD lesspipe-1.83-r1.ebuild 1134 BLAKE2B 0593da935bf18e040e0d9859e051d867fde05644ba39b7c71bf8ac6a60e9a5581deb74fcb3884c0370e7947f23a6b8802bb6c53685dd2c772139bda286252d49 SHA512 dd9ef9aab18b1b1b3ce69436963ccd577fba41c9e6dedbf69aabf7c61093bb04c0b2ea3bf9e62e25304f8008ea81730407fe410c208a85aece54e6d4a05c400c
EBUILD lesspipe-1.83.ebuild 1147 BLAKE2B a6d4741acd7713b6231dbaedaacef655a2ac1cb0bf1df903dc771318e42cecb5e6001d3aff9c8d46c344514e9d00112d469aa65e785b7f474be520e671acff67 SHA512 a20258832d481689afaae1a9ac9234ce407e6d5746617a159bb49452bf82965f25039cfd5e65c79175039808a08de30aef7d3c8898ac9a5ca548d838b2489085
MISC metadata.xml 303 BLAKE2B 57a0ab69188055eec0a29d4f2e331dd027d87b12623099013f889cd4954574772f3279c7fdce85c0fe627083db59a89a6d3daed8266c867b17bbdf84d1fef4a5 SHA512 efdd1963073db285de7f83ff804fdc98876846cb011fa0c8aa65f9b3c1dd6b7cdb039ca6a7a03018edfdff930f817208bb29601bb0c5571fc16d637615e0c7b7
diff --git a/app-text/lesspipe/lesspipe-1.83-r1.ebuild b/app-text/lesspipe/lesspipe-1.83-r1.ebuild
new file mode 100644
index 000000000000..92d625cc3641
--- /dev/null
+++ b/app-text/lesspipe/lesspipe-1.83-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="a preprocessor for less"
+HOMEPAGE="https://github.com/wofr06/lesspipe"
+SRC_URI="https://www-zeuthen.desy.de/~friebel/unix/less/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ !<sys-apps/less-483-r1"
+
+src_configure() {
+ # Not an autoconf script.
+ ./configure --fixed || die
+}
+
+src_compile() {
+ # Nothing to build.
+ :
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}/usr" DESTDIR="${D}" install
+ einstalldocs
+}
+
+pkg_preinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "This package installs 'lesspipe.sh' which is distinct from 'lesspipe'."
+ elog "The latter is the Gentoo-specific version. Make sure to update your"
+ elog "LESSOPEN environment variable if you wish to use this copy."
+ fi
+}