summaryrefslogtreecommitdiff
path: root/app-text/krop/krop-0.5.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/krop/krop-0.5.1.ebuild')
-rw-r--r--app-text/krop/krop-0.5.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-text/krop/krop-0.5.1.ebuild b/app-text/krop/krop-0.5.1.ebuild
new file mode 100644
index 000000000000..21e6ff172169
--- /dev/null
+++ b/app-text/krop/krop-0.5.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit eutils distutils-r1 xdg-utils
+
+DESCRIPTION="A tool to crop PDF files"
+HOMEPAGE="http://arminstraub.com/software/krop"
+SRC_URI="http://arminstraub.com/downloads/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/python-poppler-qt5[${PYTHON_USEDEP}]
+ dev-python/PyPDF2[${PYTHON_USEDEP}]
+ dev-python/PyQt5[${PYTHON_USEDEP}]"
+
+src_install() {
+ distutils-r1_src_install
+ domenu "${WORKDIR}/${P}/${PN}.desktop"
+}
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}