summaryrefslogtreecommitdiff
path: root/app-text/jabref-bin/jabref-bin-4.3.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/jabref-bin/jabref-bin-4.3.1.ebuild')
-rw-r--r--app-text/jabref-bin/jabref-bin-4.3.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-text/jabref-bin/jabref-bin-4.3.1.ebuild b/app-text/jabref-bin/jabref-bin-4.3.1.ebuild
new file mode 100644
index 000000000000..a4bf511e4d47
--- /dev/null
+++ b/app-text/jabref-bin/jabref-bin-4.3.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_WANT_TARGET=1.8
+
+inherit eutils java-pkg-2
+
+MY_PV_1="${PV/_beta/b}"
+MY_PV="${MY_PV_1/_rc/}"
+MY_URI_PV_1="${PV/rc/}"
+MY_URI_PV="${MY_URI_PV_1//_/%20}"
+
+DESCRIPTION="Java GUI for managing BibTeX and other bibliographies"
+HOMEPAGE="http://www.jabref.org/"
+SRC_URI="https://github.com/JabRef/jabref/releases/download/v${PV}/JabRef-${MY_PV}.jar"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/unzip"
+
+RDEPEND="
+ || (
+ dev-java/oracle-jre-bin:1.8[javafx]
+ dev-java/oracle-jdk-bin:1.8[javafx]
+ )
+ >=virtual/jre-1.8
+"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp -v "${DISTDIR}/${A}" . || die
+ unzip ${A} images/external/JabRef-icon-128.png || die
+}
+
+src_install() {
+ java-pkg_newjar "JabRef-${MY_PV}.jar"
+ java-pkg_dolauncher "${PN}" --jar "${PN}.jar"
+ newicon images/external/JabRef-icon-128.png JabRef-bin-icon.png
+ make_desktop_entry "${PN}" JabRef-bin JabRef-bin-icon Office
+ ewarn "Jabref 4.x will convert old 3.x format .bib databases to a new format."
+ ewarn "The conversion is irreversible, backup .bib files before starting Jabref."
+ ewarn "Jabref 4.x is under heavy development and very unstable."
+}