summaryrefslogtreecommitdiff
path: root/app-text/jabref-bin/jabref-bin-2.10.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/jabref-bin/jabref-bin-2.10.ebuild')
-rw-r--r--app-text/jabref-bin/jabref-bin-2.10.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-text/jabref-bin/jabref-bin-2.10.ebuild b/app-text/jabref-bin/jabref-bin-2.10.ebuild
new file mode 100644
index 000000000000..0820eb6e6bc6
--- /dev/null
+++ b/app-text/jabref-bin/jabref-bin-2.10.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils java-pkg-2
+
+MY_PV_1="${PV/_beta/b}"
+MY_PV="${MY_PV_1/_rc/}"
+
+DESCRIPTION="Java GUI for managing BibTeX and other bibliographies"
+HOMEPAGE="http://jabref.sourceforge.net/"
+SRC_URI="mirror://sourceforge/jabref/JabRef-${MY_PV}.jar"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND=">=virtual/jre-1.6"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp -v "${DISTDIR}/${A}" . || die
+}
+
+src_install() {
+ java-pkg_newjar JabRef-${MY_PV}.jar
+ java-pkg_dolauncher ${PN} --jar ${PN}.jar
+}