summaryrefslogtreecommitdiff
path: root/app-text/htmlrecode
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/htmlrecode')
-rw-r--r--app-text/htmlrecode/Manifest3
-rw-r--r--app-text/htmlrecode/htmlrecode-1.3.1-r1.ebuild41
-rw-r--r--app-text/htmlrecode/htmlrecode-1.3.1.ebuild6
3 files changed, 46 insertions, 4 deletions
diff --git a/app-text/htmlrecode/Manifest b/app-text/htmlrecode/Manifest
index b836a9ca9619..80d944afacbb 100644
--- a/app-text/htmlrecode/Manifest
+++ b/app-text/htmlrecode/Manifest
@@ -1,4 +1,5 @@
AUX htmlrecode-1.3.1-ar.patch 187 BLAKE2B 2931aec68270d9c9bd91c494eea1598915713eb5d80433e95f12a1fa4f432bc0238eb02f77361090ea8525aaab9027b753b62bb6b44109e4f83659de5efc8d10 SHA512 a49a858d317a8eaaf5ac5079763e04f043c5471519dd7f362ccb621ec43b13841c31a24436d255f5386982bd78ae6182ad7c5bf990e4c4164ec800ac616a9df8
DIST htmlrecode-1.3.1.tar.bz2 51387 BLAKE2B 7aee0e5c6c5c3c599ccaff76c7bd2e36b63857e96429c582eeda5f16cce6c1ceeb1bff929c4ea03f8bb6ad0154b92a90e53132334c7e59f365e5541b87c65e97 SHA512 180b9c2a1214007bd3163d5df7bcf15c299f452b78f0383a01d85d48212d8ae32c2b5598f44c40ce54b332c26f3ee5c448c614fbae383ec9a326e44f69b0ad10
-EBUILD htmlrecode-1.3.1.ebuild 797 BLAKE2B e7237847d3bee9245ca86da02a5c71cfff6043a460693b6fa0745633d313783259f561ce82fae4d4bb1a7e521c9a4153186f5ba48b5fb15c24d1f0572b6cb10f SHA512 3a837a54b2b4de230fe75cc156cdc94a1a316fb41db76285ee8de5508f3692d731c99baf721cd8476cb22102e4d1fdec33c3c91f9ffbd8cabb6e1158475a162f
+EBUILD htmlrecode-1.3.1-r1.ebuild 774 BLAKE2B f3f4931263c7c6e64c6657b80082a9efbec307311974c4ae536d52791f622a8982ce1107b5b359c3666125adbb35d4c37979a4f404494774f774ad4ef1a087d5 SHA512 43618c5df87e122fdcecbf85c29c56b14c781e105a5fe54e2179aa553391845fdbecd5826ccef749892507c0b6792977387f66ebc7f514d8b3310ee79d650351
+EBUILD htmlrecode-1.3.1.ebuild 799 BLAKE2B 692d9396916f975c3e1640785c61a518dddcd90e1811024762000f94b22a92d8e565a2fa6b15b531b04f0acf1bf1bb462f15c9581127288a4f1ff16d31b97ee2 SHA512 5bac586cc6a9255fa8bcc18faa9f2cae07a8a1511b7cba695fb187f1196a92aed95021bab696edeec1501089bc1323be1785da6c61a732feaf6798b8652a867a
MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-text/htmlrecode/htmlrecode-1.3.1-r1.ebuild b/app-text/htmlrecode/htmlrecode-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..4b9258115b94
--- /dev/null
+++ b/app-text/htmlrecode/htmlrecode-1.3.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Recodes HTML file using a new character set"
+HOMEPAGE="https://bisqwit.iki.fi/source/htmlrecode.html"
+SRC_URI="https://bisqwit.iki.fi/src/arch/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+PATCHES=( "${FILESDIR}/${P}-ar.patch" )
+
+src_prepare() {
+ touch .depend argh/.depend || die
+ default
+}
+
+src_configure() { :; }
+
+src_compile() {
+ local makeopts=(
+ AR="$(tc-getAR)"
+ CPPDEBUG=
+ CXX="$(tc-getCXX)"
+ CXXFLAGS="${CXXFLAGS}"
+ LDFLAGS="${LDFLAGS}"
+ )
+ emake "${makeopts[@]}" -C argh libargh.a
+ emake "${makeopts[@]}" htmlrecode
+}
+
+src_install() {
+ dobin htmlrecode
+ dodoc README.html
+}
diff --git a/app-text/htmlrecode/htmlrecode-1.3.1.ebuild b/app-text/htmlrecode/htmlrecode-1.3.1.ebuild
index 62baa2ad62e0..1174c57d9c79 100644
--- a/app-text/htmlrecode/htmlrecode-1.3.1.ebuild
+++ b/app-text/htmlrecode/htmlrecode-1.3.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=4
@@ -6,8 +6,8 @@ EAPI=4
inherit eutils toolchain-funcs
DESCRIPTION="Recodes HTML file using a new character set"
-HOMEPAGE="http://bisqwit.iki.fi/source/htmlrecode.html"
-SRC_URI="http://bisqwit.iki.fi/src/arch/${P}.tar.bz2"
+HOMEPAGE="https://bisqwit.iki.fi/source/htmlrecode.html"
+SRC_URI="https://bisqwit.iki.fi/src/arch/${P}.tar.bz2"
KEYWORDS="~amd64 ~ppc ~x86"
LICENSE="GPL-2"