summaryrefslogtreecommitdiff
path: root/app-text/gspell
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/gspell')
-rw-r--r--app-text/gspell/Manifest2
-rw-r--r--app-text/gspell/gspell-1.8.1.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/app-text/gspell/Manifest b/app-text/gspell/Manifest
index c2aa68ea2f9e..9578db8569de 100644
--- a/app-text/gspell/Manifest
+++ b/app-text/gspell/Manifest
@@ -1,3 +1,5 @@
DIST gspell-1.6.1.tar.xz 416704 BLAKE2B 2a180bc52d3f09813d8de362e5bf900f831663c09530c8a9b993baf55f852a3939447a71c9c9dc0caafba7e8b74a2a5aad4443cf248eb87da4e15e0481e74262 SHA512 f1ffbd0d23d9743bcf924c25b3a3d7bf93c6a5e4ea5e362fb7300f657d8c1d0117e847f3dec29de377947f850e003b24a3231e88e99b313c955dd94ce358c23e
+DIST gspell-1.8.1.tar.xz 419268 BLAKE2B f32c9c518c23f8f560d65eb6fb122703561cc09e385eefa99d0761e8aa5b5bf3a8cec3cab7071043134314262979de56d08ee2929973b7968016b123e53d8f16 SHA512 ae94f46c7bdcdeefa0279cd4ac3c50e53b63092016e298ef6b502c40c2574a2135c503ab322f5a3a7b8b4422fdec291a6ed0c937683a8c0f32d7ad474cc1569b
EBUILD gspell-1.6.1.ebuild 1029 BLAKE2B e788cc6815412d4cfd157bf37700e38fd3604ab1ca51a2f7bd51c560a126ab5de9a9b8d1303d02f8da22de4207813693771469d0d80730bd91b6386559204073 SHA512 bceaaa706a10c980c184738664a0645c6e70d13ed3fd2a10e7ebd62daf51f502dc475794eb5782beb7f7bfa2f2a8974da8e4ef0fce76ab35e2b9d532a5c65100
+EBUILD gspell-1.8.1.ebuild 1031 BLAKE2B 0c22cda83a62fdea9ffd07cd5cf2c8635d38bcfc259bbd092572745687220f949391742a7d6c8574c8bc8c70a2bc8945b41a30c1c92c688fb020e06941b0fd5c SHA512 822f18b8dc5fe96a150de0482d304263ea3ce75b21afed141dbdd242db1739eae1acc5797a3535c50e1ec710310d59e6ad0d10b11b0d3ba6c162aa278fe1136b
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/app-text/gspell/gspell-1.8.1.ebuild b/app-text/gspell/gspell-1.8.1.ebuild
new file mode 100644
index 000000000000..3226d1b01c67
--- /dev/null
+++ b/app-text/gspell/gspell-1.8.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="Spell check library for GTK+ applications"
+HOMEPAGE="https://wiki.gnome.org/Projects/gspell"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/1" # subslot = libgspell-1 soname version
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+
+IUSE="+introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ app-text/iso-codes
+ >=app-text/enchant-2.1.3
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.20:3[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.42.0:= )
+ vala? ( $(vala_depend) )
+"
+DEPEND="${RDEPEND}
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.25
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
+
+src_test() {
+ virtx emake check
+}