summaryrefslogtreecommitdiff
path: root/app-text/feathernotes/feathernotes-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/feathernotes/feathernotes-9999.ebuild')
-rw-r--r--app-text/feathernotes/feathernotes-9999.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-text/feathernotes/feathernotes-9999.ebuild b/app-text/feathernotes/feathernotes-9999.ebuild
new file mode 100644
index 000000000000..880fc704e847
--- /dev/null
+++ b/app-text/feathernotes/feathernotes-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit git-r3 cmake xdg
+
+DESCRIPTION=" Lightweight Qt Notes-Manager for Linux"
+HOMEPAGE="https://github.com/tsujan/FeatherNotes"
+EGIT_REPO_URI="https://github.com/tsujan/FeatherNotes"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="spell X"
+
+RDEPEND="
+ dev-qt/qtbase:6[dbus,gui,network,widgets,xml,X?]
+ dev-qt/qtsvg:6
+ spell? ( app-text/hunspell:= )
+ X? ( x11-libs/libX11 )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+BDEPEND="dev-qt/qttools:6[linguist]"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITHOUT_X11=$(usex !X)
+ -DWITH_HUNSPELL=$(usex spell)
+ )
+ cmake_src_configure
+}