summaryrefslogtreecommitdiff
path: root/app-text/feathernotes/feathernotes-1.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/feathernotes/feathernotes-1.2.0.ebuild')
-rw-r--r--app-text/feathernotes/feathernotes-1.2.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-text/feathernotes/feathernotes-1.2.0.ebuild b/app-text/feathernotes/feathernotes-1.2.0.ebuild
new file mode 100644
index 000000000000..3f3075fd6e7a
--- /dev/null
+++ b/app-text/feathernotes/feathernotes-1.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION=" Lightweight Qt Notes-Manager for Linux"
+HOMEPAGE="https://github.com/tsujan/FeatherNotes"
+SRC_URI="https://github.com/tsujan/FeatherNotes/archive/V${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/FeatherNotes-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="spell X"
+
+RDEPEND="
+ dev-qt/qtbase:6[dbus,gui,network,widgets,xml,X?]
+ dev-qt/qtsvg:6
+ spell? ( app-text/hunspell:= )
+ X? ( x11-libs/libX11 )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+BDEPEND="dev-qt/qttools:6[linguist]"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITHOUT_X11=$(usex !X)
+ -DWITH_HUNSPELL=$(usex spell)
+ )
+ cmake_src_configure
+}