summaryrefslogtreecommitdiff
path: root/app-text/enchant/enchant-2.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/enchant/enchant-2.5.0.ebuild')
-rw-r--r--app-text/enchant/enchant-2.5.0.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/app-text/enchant/enchant-2.5.0.ebuild b/app-text/enchant/enchant-2.5.0.ebuild
index 127c7ab47e6b..22f22e0ed91a 100644
--- a/app-text/enchant/enchant-2.5.0.ebuild
+++ b/app-text/enchant/enchant-2.5.0.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+inherit libtool
+
DESCRIPTION="Spellchecker wrapping library"
HOMEPAGE="https://abiword.github.io/enchant/"
SRC_URI="https://github.com/AbiWord/enchant/releases/download/v${PV}/${P}.tar.gz"
@@ -37,6 +39,11 @@ QA_CONFIG_IMPL_DECL_SKIP=(
alignof
)
+src_prepare() {
+ default
+ elibtoolize
+}
+
src_configure() {
local myconf=(
--disable-static