summaryrefslogtreecommitdiff
path: root/app-text/editorconfig-core-c/editorconfig-core-c-0.12.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/editorconfig-core-c/editorconfig-core-c-0.12.5.ebuild')
-rw-r--r--app-text/editorconfig-core-c/editorconfig-core-c-0.12.5.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/app-text/editorconfig-core-c/editorconfig-core-c-0.12.5.ebuild b/app-text/editorconfig-core-c/editorconfig-core-c-0.12.5.ebuild
deleted file mode 100644
index 37b393829999..000000000000
--- a/app-text/editorconfig-core-c/editorconfig-core-c-0.12.5.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="EditorConfig core library written in C"
-HOMEPAGE="https://github.com/editorconfig/editorconfig-core-c/"
-SRC_URI="https://github.com/editorconfig/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~loong ~ppc64 ~riscv x86"
-IUSE="cli doc"
-
-BDEPEND="doc? ( app-text/doxygen )"
-DEPEND="dev-libs/libpcre2:="
-RDEPEND="${DEPEND}
- cli? ( !dev-python/editorconfig[cli] )"
-
-src_prepare() {
- # Don't install the static library.
- sed -e '/install(TARGETS editorconfig_static/,+5d' -i src/lib/CMakeLists.txt || die
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_DOCUMENTATION=$(usex doc 'ON' 'OFF')
- -DBUILD_STATICALLY_LINKED_EXE=OFF
- )
- cmake_src_configure
-}
-
-src_install() {
- use doc && local HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
- cmake_src_install
-
- if ! use cli; then
- rm -r "${ED}/usr/bin" || die
- fi
-}