summaryrefslogtreecommitdiff
path: root/app-text/doxygen/files
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/doxygen/files')
-rw-r--r--app-text/doxygen/files/doxygen-1.9.1-do_not_force_libcxx.patch13
-rw-r--r--app-text/doxygen/files/doxygen-1.9.1-ignore-bad-encoding.patch23
2 files changed, 0 insertions, 36 deletions
diff --git a/app-text/doxygen/files/doxygen-1.9.1-do_not_force_libcxx.patch b/app-text/doxygen/files/doxygen-1.9.1-do_not_force_libcxx.patch
deleted file mode 100644
index f33f619e62ed..000000000000
--- a/app-text/doxygen/files/doxygen-1.9.1-do_not_force_libcxx.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 3775ed1..b3a1af6 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -23,7 +23,7 @@ option(build_doc "Build user manual (HTML and PDF)" OFF)
- option(build_doc_chm "Build user manual (CHM)" OFF)
- option(use_sqlite3 "Add support for sqlite3 output [experimental]." OFF)
- if (CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
-- option(use_libc++ "Use libc++ as C++ standard library." ON)
-+ option(use_libc++ "Use libc++ as C++ standard library." OFF)
- endif()
- option(use_libclang "Add support for libclang parsing." OFF)
- option(static_libclang "Link to a statically compiled version of LLVM/libclang." OFF)
diff --git a/app-text/doxygen/files/doxygen-1.9.1-ignore-bad-encoding.patch b/app-text/doxygen/files/doxygen-1.9.1-ignore-bad-encoding.patch
deleted file mode 100644
index 5dd7578f24ec..000000000000
--- a/app-text/doxygen/files/doxygen-1.9.1-ignore-bad-encoding.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Hack to avoid "UnicodeDecodeError: 'utf-8' codec can't decode byte 0xb0 in position 45: invalid start byte"
-in src/._xmlgen.cpp which is binary. This doesn't seem like it should be present at the time the docs
-are generated, but this is simpler for now.
---- a/doc/translator.py
-+++ b/doc/translator.py
-@@ -1454,10 +1454,13 @@ class TrManager:
-
- # Read content of the file as one string.
- assert os.path.isfile(fname)
-- f = xopen(fname)
-- cont = f.read()
-- cont = ''.join(cont.split('\n')) # otherwise the 'match' function won't work.
-- f.close()
-+ try:
-+ with xopen(fname) as f:
-+ cont = f.read()
-+ cont = ''.join(cont.split('\n')) # otherwise the 'match' function won't work.
-+ except UnicodeDecodeError:
-+ print("Skipping {0} because of decoding errors".format(fname))
-+ return
-
- # Remove the items for identifiers that were found in the file.
- while lst_in: