summaryrefslogtreecommitdiff
path: root/app-text/csvfix/files
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/csvfix/files')
-rw-r--r--app-text/csvfix/files/csvfix-1.10a-tests.patch51
-rw-r--r--app-text/csvfix/files/csvfix-1.6-makefile.patch69
-rw-r--r--app-text/csvfix/files/csvfix-1.6-shuffle-test.patch20
3 files changed, 0 insertions, 140 deletions
diff --git a/app-text/csvfix/files/csvfix-1.10a-tests.patch b/app-text/csvfix/files/csvfix-1.10a-tests.patch
deleted file mode 100644
index 8e4461d85a31..000000000000
--- a/app-text/csvfix/files/csvfix-1.10a-tests.patch
+++ /dev/null
@@ -1,51 +0,0 @@
---- csvfix-build.orig/csvfix/tests/run1
-+++ csvfix-build/csvfix/tests/run1
-@@ -1,4 +1,4 @@
--#!bash
-+#!/bin/bash
- # run1
- # run single test
- # copyright (C) 2008 Neil Butterworth
-@@ -49,7 +49,7 @@
- fi
-
- # exe to be tested - used in tests
--CSVED=../bin/csvfix.exe
-+CSVED=../bin/csvfix
- export CSVED
-
- if [ ! -f "$CSVED" ]
-@@ -64,7 +64,7 @@
- fi
-
- # where to find diff & where to put output
--DIFF=/bin/diff
-+DIFF=/usr/bin/diff
- DIFFOUT=tmp/_diffout
- WINDIFF="C:/Program Files/Microsoft Visual Studio/Common/Tools/WINDIFF.EXE"
- TEST=`basename $TEST`
-@@ -133,5 +133,7 @@
- fi
- else
- echo "Execution problem with $TEST - please correct"
-+ color_red "FAILED $TEST"
-+ exit 1
- fi
-
---- csvfix-build.orig/csvfix/tests/runtests
-+++ csvfix-build/csvfix/tests/runtests
-@@ -1,4 +1,4 @@
--#!bash
-+#!/bin/bash
- # runall.bash
- # run all tests and report
-
-@@ -22,3 +22,8 @@
- echo $FAILS failed, $PASSES passed
- echo ""
-
-+if [[ $FAILS -gt 0 ]]; then
-+ exit 1
-+else
-+ exit 0
-+fi
diff --git a/app-text/csvfix/files/csvfix-1.6-makefile.patch b/app-text/csvfix/files/csvfix-1.6-makefile.patch
deleted file mode 100644
index aaee2aa003f7..000000000000
--- a/app-text/csvfix/files/csvfix-1.6-makefile.patch
+++ /dev/null
@@ -1,69 +0,0 @@
---- neilb-csvfix-e804a794d175/alib/Makefile
-+++ neilb-csvfix-e804a794d175/alib/Makefile
-@@ -2,12 +2,12 @@
- # Copyright (C) 2009 Neil Butterworth
-
- OUT = lib/alib.a
-+AR = ar
- CCTYPE = gcc
- IDIR = inc
- ODIR = obj
--XDIR = expat
- SDIR = src
--INC = -Iinc -Iexpat
-+INC = -Iinc
-
- cc.gcc = g++
- cc.clang = clang++ -std=c++11 -stdlib=libc++
-@@ -26,9 +26,6 @@
- _WINOBJS = a_db.o a_dir.o a_opsys.o a_winerr.o
- WINOBJS = $(patsubst %,$(ODIR)/%,$(_WINOBJS))
-
--_EXPAT = xmlparse.o xmlrole.o xmltok.o xmltok_impl.o xmltok_ns.o
--EXPAT = $(patsubst %,$(ODIR)/%,$(_EXPAT))
--
- $(ODIR)/%.o: $(SDIR)/%.cpp $(IDIR)/%.h
- $(CC) -c $(INC) $(CFLAGS) -o $@ $<
-
-@@ -36,10 +33,10 @@
- $(CC) -c $(INC) $(CFLAGS) -o $@ $<
-
- win: $(OBJS) $(EXPAT) $(WINOBJS)
-- ar rvs $(OUT) $^
-+ $(AR) rvs $(OUT) $^
-
- lin: $(OBJS) $(EXPAT)
-- ar rvs $(OUT) $^
-+ $(AR) rvs $(OUT) $^
-
- .PHONY: clean
- clean:
---- neilb-csvfix-e804a794d175/csvfix/Makefile
-+++ neilb-csvfix-e804a794d175/csvfix/Makefile
-@@ -22,7 +22,7 @@
-
- ALIB = ../alib/lib/alib.a
- WINLIBS = ../alib/lib/alib.a -lodbc32
--LINLIBS = ../alib/lib/alib.a
-+LINLIBS = ../alib/lib/alib.a -lexpat
-
- _OBJS = csved_atable.o \
- csved_block.o \
-@@ -99,8 +99,7 @@
- strip $(WINOUT)
-
- $(LINOUT): $(OBJS) $(ALIB)
-- $(CC) -o $@ $^ $(LINLIBS)
-- strip $(LINOUT)
-+ $(CC) $(LDFLAGS) -o $@ $^ $(LINLIBS)
-
- .PHONY: win
- win:
---- neilb-csvfix-e804a794d175/Makefile
-+++ neilb-csvfix-e804a794d175/Makefile
-@@ -1,3 +1,5 @@
-+CFLAGS += -std=c++11
-+
- ifndef COMSPEC
- CLEAN = (cd alib; $(MAKE) clean) && (cd csvfix; $(MAKE) clean)
- else
diff --git a/app-text/csvfix/files/csvfix-1.6-shuffle-test.patch b/app-text/csvfix/files/csvfix-1.6-shuffle-test.patch
deleted file mode 100644
index 3916e92e0592..000000000000
--- a/app-text/csvfix/files/csvfix-1.6-shuffle-test.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Fix the expected data output for the shuffle test.
-
---- a/csvfix/tests/correct/shuffle.test
-+++ b/csvfix/tests/correct/shuffle.test
-@@ -5,10 +5,10 @@
- "Oscar","Wilde","M"
- "Charles","Dickens","M"
- "George","Elliot","F"
--"Charles","Dickens","M"
--"Austen","F","Jane"
-+"Charles","M","Dickens"
-+"Jane","F","Austen"
- "Herman","M","Melville"
- "M","Flann","O'Brien"
--"Elliot","George","F"
--"Virginia","Woolf","F"
--"M","Wilde","Oscar"
-+"George","F","Elliot"
-+"Woolf","F","Virginia"
-+"Wilde","M","Oscar"