summaryrefslogtreecommitdiff
path: root/app-text/crqt-ng/crqt-ng-1.0.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/crqt-ng/crqt-ng-1.0.12.ebuild')
-rw-r--r--app-text/crqt-ng/crqt-ng-1.0.12.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/app-text/crqt-ng/crqt-ng-1.0.12.ebuild b/app-text/crqt-ng/crqt-ng-1.0.12.ebuild
deleted file mode 100644
index 17278e64b54d..000000000000
--- a/app-text/crqt-ng/crqt-ng-1.0.12.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-PLOCALES="bg cs hu nl ru uk"
-inherit cmake plocale xdg
-
-DESCRIPTION="Cross-platform e-book reader"
-HOMEPAGE="https://gitlab.com/coolreader-ng/crqt-ng"
-SRC_URI="https://gitlab.com/coolreader-ng/${PN}/-/archive/${PV}/${P}.tar.bz2"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="+gif +svg +chm +harfbuzz +libunibreak +fribidi +zstd +libutf8proc"
-
-CDEPEND=">=app-text/crengine-ng-0.9.7:0=[png,jpeg,fontconfig,gif=,svg=,chm=,harfbuzz=,fribidi=,zstd=,libutf8proc=]
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5"
-RDEPEND="${CDEPEND}"
-BDEPEND="${CDEPEND}
- dev-qt/linguist-tools:5"
-
-src_prepare() {
- cmake_src_prepare
- xdg_environment_reset
-
- # locales
- plocale_find_changes "${S}"/src/i18n 'crqt_' '.ts'
- sed -e "s|set(LANGUAGES .*)|set(LANGUAGES $(plocale_get_locales))|i" \
- -i "${S}"/src/CMakeLists.txt \
- || die "sed CMakeLists.txt failed"
-}
-
-src_configure() {
- CMAKE_USE_DIR="${S}"
- CMAKE_BUILD_TYPE="Release"
- local mycmakeargs=(-DUSE_QT=QT5)
- cmake_src_configure
-}