summaryrefslogtreecommitdiff
path: root/app-text/bibletime/bibletime-2.11.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/bibletime/bibletime-2.11.2.ebuild')
-rw-r--r--app-text/bibletime/bibletime-2.11.2.ebuild34
1 files changed, 24 insertions, 10 deletions
diff --git a/app-text/bibletime/bibletime-2.11.2.ebuild b/app-text/bibletime/bibletime-2.11.2.ebuild
index ebbcd684ed65..f148b08c8277 100644
--- a/app-text/bibletime/bibletime-2.11.2.ebuild
+++ b/app-text/bibletime/bibletime-2.11.2.ebuild
@@ -1,20 +1,22 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils
+VIRTUALX_REQUIRED=test
-DESCRIPTION="Qt Bible study application using the SWORD library"
-HOMEPAGE="http://www.bibletime.info/"
+inherit cmake virtualx
+
+DESCRIPTION="Qt Bible-study application using the SWORD library"
+HOMEPAGE="http://bibletime.info/"
SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug"
+KEYWORDS="amd64 x86"
-# bug 313657
+# Some tests fail due to being unable to find an icon directory relative
+# to ${WORKDIR}, some others segfault. Needs work.
RESTRICT="test"
RDEPEND="
@@ -23,6 +25,7 @@ RDEPEND="
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtprintsupport:5
+ dev-qt/qtsvg:5
dev-qt/qtwebchannel:5
dev-qt/qtwebengine:5
dev-qt/qtwidgets:5
@@ -36,12 +39,23 @@ DEPEND="${RDEPEND}
net-misc/curl
sys-libs/zlib
"
+#BDEPEND="test? (
+# app-dicts/sword-Josephus
+# app-dicts/sword-KJV
+# app-dicts/sword-KJVA
+# app-dicts/sword-Scofield
+# app-dicts/sword-StrongsGreek
+#)"
DOCS=( ChangeLog README.md )
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
sed -e "s:Dictionary;Qt:Dictionary;Office;TextTools;Utility;Qt:" \
- -i cmake/platforms/linux/bibletime.desktop.cmake || die "fixing .desktop file failed"
+ -i cmake/platforms/linux/bibletime.desktop.cmake || die "fixing .desktop file failed"
+}
+
+src_test() {
+ virtx cmake_src_test || die "Test run has failed"
}