summaryrefslogtreecommitdiff
path: root/app-text/active-dvi/active-dvi-1.10.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/active-dvi/active-dvi-1.10.2-r1.ebuild')
-rw-r--r--app-text/active-dvi/active-dvi-1.10.2-r1.ebuild73
1 files changed, 0 insertions, 73 deletions
diff --git a/app-text/active-dvi/active-dvi-1.10.2-r1.ebuild b/app-text/active-dvi/active-dvi-1.10.2-r1.ebuild
deleted file mode 100644
index ab1bc39469ff..000000000000
--- a/app-text/active-dvi/active-dvi-1.10.2-r1.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils autotools texlive-common
-
-MY_PN=${PN/ctive-/}
-MY_P=${MY_PN}-${PV}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="A DVI previewer and a presenter for slides written in LaTeX"
-SRC_URI="http://gallium.inria.fr/advi/${MY_P}.tar.gz"
-HOMEPAGE="http://gallium.inria.fr/advi/"
-LICENSE="LGPL-2.1"
-
-IUSE="+ocamlopt"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc x86"
-
-RDEPEND=">=dev-lang/ocaml-3.11.2:=[ocamlopt?]
- >=dev-ml/camlimages-4.0.1:=[truetype,tiff,jpeg,postscript,X]
- virtual/latex-base
- app-text/ghostscript-gpl
- x11-libs/libXinerama"
-DEPEND="${RDEPEND}
- dev-texlive/texlive-pstricks
- dev-texlive/texlive-pictures
- dev-texlive/texlive-latexextra
- x11-base/xorg-proto
- dev-ml/findlib
- app-text/htmlc
- dev-tex/hevea"
-
-DOCS=( "README" "TODO" )
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-1.9-htmlcflags.patch"
- AT_M4DIR="." eautoreconf
-}
-
-src_configure() {
- TEXMFMAIN="${EPREFIX}"/usr/share/texmf-site econf $(use_enable ocamlopt native-program) \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" --enable-dependency-tracking #486066
-}
-
-src_compile() {
- export VARTEXFONTS="${T}/fonts"
- emake
- cd doc || die
- emake splash.dvi scratch_write_splash.dvi scratch_draw_splash.dvi
-}
-
-src_install() {
- emake DESTDIR="${D}" PACKAGE="${PF}" install
-
- # now install the documentation
- dodoc ${DOCS}
-
- export STRIP_MASK="*/bin/advi.byt"
-
- for i in "${ED}/usr/share/doc/${PF}/"*.dvi ; do
- docompress -x /usr/share/doc/${PF}/$(basename $i)
- done
-}
-
-pkg_postinst() {
- etexmf-update
-}
-
-pkg_postrm() {
- etexmf-update
-}