summaryrefslogtreecommitdiff
path: root/app-shells
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/Manifest.gzbin8957 -> 9452 bytes
-rw-r--r--app-shells/posh-dotnet/Manifest3
-rw-r--r--app-shells/posh-dotnet/metadata.xml13
-rw-r--r--app-shells/posh-dotnet/posh-dotnet-1.2.3.ebuild39
-rw-r--r--app-shells/posh-git/Manifest3
-rw-r--r--app-shells/posh-git/metadata.xml14
-rw-r--r--app-shells/posh-git/posh-git-1.1.0.ebuild36
-rw-r--r--app-shells/posh-z/Manifest3
-rw-r--r--app-shells/posh-z/metadata.xml13
-rw-r--r--app-shells/posh-z/posh-z-1.1.12_p20230811.ebuild43
10 files changed, 167 insertions, 0 deletions
diff --git a/app-shells/Manifest.gz b/app-shells/Manifest.gz
index ec1e4f27769b..f6f0abe3f4fe 100644
--- a/app-shells/Manifest.gz
+++ b/app-shells/Manifest.gz
Binary files differ
diff --git a/app-shells/posh-dotnet/Manifest b/app-shells/posh-dotnet/Manifest
new file mode 100644
index 000000000000..ccdf80802a48
--- /dev/null
+++ b/app-shells/posh-dotnet/Manifest
@@ -0,0 +1,3 @@
+DIST posh-dotnet-1.2.3.tar.gz 27996 BLAKE2B 88c6c771c5a8df6dc98785d11a586347b2ca167fd2353d373e371c40fa8b9f8385c6706ac9d9473a8a5d07a432a60e72644e69d806c298a9369dd2dc4e778266 SHA512 020d039ba3818cdc4861132514a2182f8093230be9647d1c18a015f095201d1df91b8622e5275db19b0ca5483357854ea5ecb840f2fdcf5a24a358705a3a5751
+EBUILD posh-dotnet-1.2.3.ebuild 909 BLAKE2B 68a4ac560db308a7adb12a4a9fd9eccc2a132765b8d2110c51436ca47dc45cf56bb025b62e9a8f9438ed67330ccd7a0c00763a33bfddd10ebc5489ed6ee5d346 SHA512 5f73ee0177108bcbd685fbce94222b4d9d5500088915e395441ca47cdfd171dcb44170684a0380332999cdb0c4c3ebfdce2b012ac023235d2b017c269544e538
+MISC metadata.xml 429 BLAKE2B ee88c7267a4fd56017a9b991130ba39b90c70f8dae1431656377989c084f08302f880003e2c8e2cdca04bd74f88af08a43ca590508ec990e7dc869933f15bffd SHA512 91ebc1ca45b1151537aa1d4bc5bacb83d8abded1a2f558e4c0ff8e9bfaa6b0d892e8892d31f5bd324d7e641840363ca4e4e0b21358fc811af4fb6cc32498719c
diff --git a/app-shells/posh-dotnet/metadata.xml b/app-shells/posh-dotnet/metadata.xml
new file mode 100644
index 000000000000..c5df59d0fe3b
--- /dev/null
+++ b/app-shells/posh-dotnet/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>dotnet@gentoo.org</email>
+ <name>Gentoo Dotnet Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://gitlab.com/bergmeister/posh-dotnet/issues/</bugs-to>
+ <remote-id type="github">bergmeister/posh-dotnet</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/posh-dotnet/posh-dotnet-1.2.3.ebuild b/app-shells/posh-dotnet/posh-dotnet-1.2.3.ebuild
new file mode 100644
index 000000000000..f0151f7e8666
--- /dev/null
+++ b/app-shells/posh-dotnet/posh-dotnet-1.2.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="PowerShell tab completion and tooltip support for the dotnet CLI"
+HOMEPAGE="https://github.com/bergmeister/posh-dotnet/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/bergmeister/${PN}.git"
+else
+ if [[ "${PV}" == 1.2.3 ]] ; then
+ COMMIT="c017886cbad9c4f6ce1fbaa38ebbbcada664655b"
+
+ SRC_URI="https://github.com/bergmeister/${PN}/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${COMMIT}
+ else
+ SRC_URI="https://github.com/bergmeister/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ fi
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="${PV}"
+RESTRICT="test" # Tests fail.
+
+RDEPEND="virtual/pwsh:*"
+
+src_install() {
+ insinto "/usr/share/GentooPowerShell/Modules/${PN}/${PV}"
+ doins "${PN}.psd1" "${PN}.psm1"
+
+ einstalldocs
+}
diff --git a/app-shells/posh-git/Manifest b/app-shells/posh-git/Manifest
new file mode 100644
index 000000000000..5d660ee17cbd
--- /dev/null
+++ b/app-shells/posh-git/Manifest
@@ -0,0 +1,3 @@
+DIST posh-git-1.1.0.tar.gz 90089 BLAKE2B 3759c8382d1e1c48cd5ee40668ae5e3f8edff3ae73861af904a1a4674af52f57e010e2f187813caf728d750b5f492d15860e58a57a24f6e3aa65fa5eb2b7a9cc SHA512 1aa8150c07d212476527c32a8a6acad903811de0068147b43810e3aa897a837c7adf69838195654ca26715ec7e736e56897190b344c6f432374b1d2493e5b891
+EBUILD posh-git-1.1.0.ebuild 711 BLAKE2B dec621edd2f03463b3fba23cb46efb3d4607430af258bf2b4b3d431dcd38d70ffd2c300eaa7f757ef56ae683645cfd4f6cdc01cc9557eea69ba9e6699844d24d SHA512 3107c0da3ca7f827ff9a13b8f8896b99691e92e61c8099be132430c312c7d2c0aa2a384fd833de6acd5d6fe710d31c28e6e011df48b3c6e5c7af171053af8566
+MISC metadata.xml 503 BLAKE2B 21d07b713e5b8fa76acd8caf7cb9dde2694b843344322bb16d3f1fef6db3bb54ba556d184c8427bb97ed5ad038b6b7fcf3c03c5188e3c21f6083a90227262895 SHA512 342cc92848846505450012dc59e2936d224ff4642c79038bda40031eaf1d8bbac880823f941ccb067d89be8f7a69185fb0c2bad7d4422857379fff846265a654
diff --git a/app-shells/posh-git/metadata.xml b/app-shells/posh-git/metadata.xml
new file mode 100644
index 000000000000..b95ffb970544
--- /dev/null
+++ b/app-shells/posh-git/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>dotnet@gentoo.org</email>
+ <name>Gentoo Dotnet Project</name>
+ </maintainer>
+ <upstream>
+ <changelog>https://github.com/dahlbyk/posh-git/blob/master/CHANGELOG.md</changelog>
+ <bugs-to>https://gitlab.com/dahlbyk/posh-git/issues/</bugs-to>
+ <remote-id type="github">dahlbyk/posh-git</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/posh-git/posh-git-1.1.0.ebuild b/app-shells/posh-git/posh-git-1.1.0.ebuild
new file mode 100644
index 000000000000..72a1c2f7cce4
--- /dev/null
+++ b/app-shells/posh-git/posh-git-1.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A PowerShell environment for Git"
+HOMEPAGE="http://dahlbyk.github.io/posh-git/
+ https://github.com/dahlbyk/posh-git/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/dahlbyk/${PN}.git"
+else
+ SRC_URI="https://github.com/dahlbyk/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="${PV}"
+
+RDEPEND="
+ virtual/pwsh:*
+ dev-vcs/git
+"
+
+DOCS=( CHANGELOG.md ISSUE_TEMPLATE.md README.md profile.example.ps1 )
+
+src_install() {
+ insinto "/usr/share/GentooPowerShell/Modules/${PN}/${PV}"
+ doins -r src/.
+
+ einstalldocs
+}
diff --git a/app-shells/posh-z/Manifest b/app-shells/posh-z/Manifest
new file mode 100644
index 000000000000..c4eedfb0cc85
--- /dev/null
+++ b/app-shells/posh-z/Manifest
@@ -0,0 +1,3 @@
+DIST posh-z-1.1.12_p20230811.tar.gz 290155 BLAKE2B 227d14c947daf121d013e4ad020a80935c87fd198e57e486d0f3598ef9c7d72d660e61b9576fecc6635226a47388d2eb9ea785762436fd177a74eeb867ad4095 SHA512 91d2173205ef5d27e9385ed5a09e6809be284488e69e4d6ca85019cdf0abfac26aaa01765c52eaee85aacd367982510bad5b3881ca3679f2e8ba19101db3cd50
+EBUILD posh-z-1.1.12_p20230811.ebuild 898 BLAKE2B d4deac861bb818de466521a28b0eae3fffd8b5412597b60b8a660d0f36dd4199526dc4432576a559e9cd05eda604a9850959b7c81dc8059f0fd862993479842c SHA512 9bfc6d53ef6d6a5beed1d38325ad003f4c6bb1b62d980b039db458f359828b54db3e40c10537662a1b11ce76a407cd0e58acc5a220076add309bab8cb93f3e69
+MISC metadata.xml 415 BLAKE2B 54ab9fc29b5dcb669179d0041f0c936eb48c43b543567e997e93f74542238a33b09375304c3dffddb1058c92e839b19198dde94d279f588e0fbf244141d72d3c SHA512 3ef0a77ce423846c09db047deb497e4a1e3e870f222b60d88df320945af0250766c7a265772788249ff0eda46beff28981bf17ff3cd5333632cf0e4f5566e189
diff --git a/app-shells/posh-z/metadata.xml b/app-shells/posh-z/metadata.xml
new file mode 100644
index 000000000000..b3ffc98a0269
--- /dev/null
+++ b/app-shells/posh-z/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>dotnet@gentoo.org</email>
+ <name>Gentoo Dotnet Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://gitlab.com/badmotorfinger/z/issues/</bugs-to>
+ <remote-id type="github">badmotorfinger/z</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/posh-z/posh-z-1.1.12_p20230811.ebuild b/app-shells/posh-z/posh-z-1.1.12_p20230811.ebuild
new file mode 100644
index 000000000000..9992bd48a310
--- /dev/null
+++ b/app-shells/posh-z/posh-z-1.1.12_p20230811.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Quickly navigate the file system based on your cd history"
+HOMEPAGE="https://github.com/badmotorfinger/z/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/badmotorfinger/z.git"
+else
+ if [[ "${PV}" == *_p20230811 ]] ; then
+ COMMIT="ca1c8d9f004eede2ba907da199bde542d9eff344"
+
+ SRC_URI="https://github.com/badmotorfinger/z/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/z-${COMMIT}"
+ else
+ SRC_URI="https://github.com/badmotorfinger/z/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/z-${PV}"
+ fi
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="public-domain"
+SLOT="${PV%%_p*}"
+
+RDEPEND="virtual/pwsh:*"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ insinto "/usr/share/GentooPowerShell/Modules/z/${SLOT}"
+ doins z.*
+
+ einstalldocs
+}