summaryrefslogtreecommitdiff
path: root/app-shells
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/Manifest.gzbin10656 -> 10658 bytes
-rw-r--r--app-shells/liquidprompt/Manifest3
-rw-r--r--app-shells/liquidprompt/liquidprompt-2.2.0.ebuild43
-rw-r--r--app-shells/platyps/Manifest2
-rw-r--r--app-shells/platyps/platyps-0.14.2.ebuild2
5 files changed, 48 insertions, 2 deletions
diff --git a/app-shells/Manifest.gz b/app-shells/Manifest.gz
index e5ce4a01cd34..7f266e5fe74f 100644
--- a/app-shells/Manifest.gz
+++ b/app-shells/Manifest.gz
Binary files differ
diff --git a/app-shells/liquidprompt/Manifest b/app-shells/liquidprompt/Manifest
index 4ce45ecbd496..d8a03bf30894 100644
--- a/app-shells/liquidprompt/Manifest
+++ b/app-shells/liquidprompt/Manifest
@@ -1,3 +1,6 @@
+DIST bash-preexec.sh 12667 BLAKE2B 1a19e3d7c2b74ae7572375b7af11c20a3506464c1ae31b90439529422ae74fcdb26f71bfa3d9128180852b511335cd79a9ab3d951aa9d4d1749c122cd3444013 SHA512 c77093d7049ad97406519e3f7bd98dbfa6ca3670c635995484aa5635a47e0243c885868dc48bb89d9f15d2c8082657eefb895e1fb764c3b9e0498cfee7797120
DIST liquidprompt-2.1.2.tar.gz 621356 BLAKE2B b5c3c52179f86fc42164e08a01f4e114f5e7ce1cdb5fb19ef1c02e85569e895cb5f1cc2f61bf6f66380d5c20bc6daf41547eb281990221528d5c1d85b61d1329 SHA512 685da50d347ba0d7c6881d87426344840cc7ab960067035b43f9658c51d7d5cf89e80f4bf8344b49f3858fe91bcfd57dcfaf9a253246fc1a7ebedbba474dc5ff
+DIST liquidprompt-2.2.0.tar.gz 986151 BLAKE2B aad40582ddb3e4f611e4632ebff0a6625d169a18d35013d204b1912196c770f04361a617c54e3c798b9828fba3919c0af328f81e1994ba3c987321b551ed9634 SHA512 1ccefcdb7b58697ac9b27e3e94ef1527c17ac36e9e405930f5b8b2a906cad5789ed9f77271dbcc66b3ef3457b307df370cfc60f88dc13e9d82ba3de7e2708421
EBUILD liquidprompt-2.1.2.ebuild 818 BLAKE2B 60c6a123ff127bec28223470cf27282530a1f756cbec3e5ee7da506d5d6a564f23018004df03c4b8b119ef1ccc616bdc364d8a3847452274a7dfb373002dde9d SHA512 bbdb46176949b2a172ec35c9658e441091b7ed1a36d30e35066df1ee101415ba0089306fa2fee6d9efe00ce4b4a1b40e38bb9f29449cf22f072185701ffe45e0
+EBUILD liquidprompt-2.2.0.ebuild 1038 BLAKE2B ea0422b9720a16a3cae2ca4e6cac684a7de09c43d82951fbebb21ffb9b0ab6846ece922f08ef60bbe75a6e37ca85bdf98a79e389484ba2cb13a53cb884411759 SHA512 e835aab3f1bfda968357423213653473cdd89cdc0acfe1f851af551a8381bfeec28b796fb07557ae3bbc214e6b80a86d8f6feee434681f91c092cd0dbf44f684
MISC metadata.xml 335 BLAKE2B 35124b3abcc1162303d8e666abc6d5e024191604555500cdf5f21ba3b45d3c815cef3e14ce4e8052b0d698f9ce4ac83fc22585382559989922816ea7128b59c6 SHA512 12fa46e8150943e9c7175079b67912a0f9cede1bc6892781eeb97c635f99243e32a24ca60a2caa3f2a19587f4c5a134b84f90f95b018c93e6a523001e0e8e806
diff --git a/app-shells/liquidprompt/liquidprompt-2.2.0.ebuild b/app-shells/liquidprompt/liquidprompt-2.2.0.ebuild
new file mode 100644
index 000000000000..8aae627d6efa
--- /dev/null
+++ b/app-shells/liquidprompt/liquidprompt-2.2.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Full-featured & carefully designed adaptive prompt for Bash & Zsh"
+HOMEPAGE="https://github.com/nojhan/liquidprompt https://liquidprompt.readthedocs.io/"
+SRC_URI="
+ https://github.com/nojhan/liquidprompt/releases/download/v${PV}/${PN}-v${PV}.tar.gz
+ -> ${P}.tar.gz
+ test? (
+ https://raw.githubusercontent.com/rcaloras/bash-preexec/0.4.1/bash-preexec.sh
+ )
+"
+S="${WORKDIR}/${PN}"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-util/shunit2 )"
+
+DOCS=( CHANGELOG.md example.bashrc README.md )
+
+src_test() {
+ cp "${DISTDIR}/bash-preexec.sh" tests/ || die
+ cp "$(type -P shunit2)" tests/shunit2 || die
+ ./tests.sh bash || die
+}
+
+src_install() {
+ default
+ dobin liquidprompt
+
+ insinto /usr/share/${PN}
+ doins -r themes templates tools
+
+ insinto /etc/
+ ./tools/config-from-doc.sh > "${T}/liquidpromptrc" || die
+ newins "${T}/liquidpromptrc" liquidpromptrc
+}
diff --git a/app-shells/platyps/Manifest b/app-shells/platyps/Manifest
index cf1c6e07c430..f71d28ad72dc 100644
--- a/app-shells/platyps/Manifest
+++ b/app-shells/platyps/Manifest
@@ -263,5 +263,5 @@ DIST xunit.extensibility.core.2.3.1.nupkg 213469 BLAKE2B 0a3acc00829a3e2cdcf083b
DIST xunit.extensibility.execution.2.3.1.nupkg 307151 BLAKE2B 827a2b661199e2167b09afbec771bb8025a3d528b6729d575075a2daafce94fec3eb3ddf9048a42d0e06a9ae2057f838768025aabfa6e53629ddf5d378fcaf89 SHA512 04f6c919dbf1d333bdc17f0538464be5954cfa2d572256683da2d0bcbb12c60b6d99dee16013526b4852f91cf8b45465f2da4fe8b134d3be52eabcb7f06f5fcd
DIST xunit.runner.visualstudio.2.3.1.nupkg 685817 BLAKE2B b9d7114631004f82556eb09eaccf4d100e02864e59711ae2042153bafb73b0677e750ad191bd388342308f98b3a86ef983e4d1f0320fac8bd46cdd0298d4ddd0 SHA512 b5b940f21c5705cc873006828f00fe6d099be04b8da0adfb141d62bf815592ce418a7650636e12a78e15ac68cfaa36d2f5993e4f6307a8af90b458f21e448915
DIST yamldotnet.5.0.0.nupkg 418351 BLAKE2B b52bfe79a2a39108246829f5946e46175c4a8382613d20789f82797cdd99097fb76e0925d7720bc54586fc1753918cb6bb05fd7731de1668c7161a97a28fcbc4 SHA512 cb8a80bdc897452c832c03d736d841b8b2b39ea6fec6a98e6f919f869b5a296e9c8a7146137cd4a503d8c57de2c84f9329bef787ae3b0b42de4520b015b17c9a
-EBUILD platyps-0.14.2.ebuild 11401 BLAKE2B 0be7eb9c5aff1cba3742727b63cbf6cf56be48ecc4cce4a0789d8a43dc1ed0c6e04a53fc72adc05e3f79b4465220be1352b49b13e9ef0e5e3c80916d623e354b SHA512 6a95a857672d27526cba7cd0b01c8d1bcf154d7cda1439373978ea90fba5f7e2d81af9ac8edd8aa9b9965cc87423facd1753697ccaba30eb92dd1b5fffded765
+EBUILD platyps-0.14.2.ebuild 11400 BLAKE2B 6f049bbb91e46c17046685a0814646db037811f315dabeac533bd8f8fe80b45d3be889964a65e23c616be61a5f1766761f49c3ea4c1afdd62c9355225bbb1016 SHA512 b551dd1ae2cb6214aa3046656a36660830bb19b55024fdbc437c973601336ae2b2da554864dc5e36ff26890b55993c47befa92950483f1231996f21bb77ca37d
MISC metadata.xml 509 BLAKE2B 1aea4fd134e94f81df1d01060d49639ea53bc46d29f5965061d5a3c5001958bdaca8a5939388471ddc55e91623be7c4cc52434a0a6c65a0f3614d4c4a12a2e00 SHA512 f26c385bc7dcfbd0fd5573b899523bf36b2ef1b104ee9f5741af24bc0479962688e1f297618d5531ad7e1cdb8a08ee694f4c3fafca3aca23c0e784d86b975d20
diff --git a/app-shells/platyps/platyps-0.14.2.ebuild b/app-shells/platyps/platyps-0.14.2.ebuild
index 7fc3c416646b..630c7987078b 100644
--- a/app-shells/platyps/platyps-0.14.2.ebuild
+++ b/app-shells/platyps/platyps-0.14.2.ebuild
@@ -342,7 +342,7 @@ src_compile() {
-Configuration "${DOTNET_PKG_CONFIGURATION}"
-DotnetCli "${DOTNET_PKG_EXECUTABLE}"
)
- edob pwsh -NoProfile -NonInteractive ./build.ps1 "${ps1opts[@]}"
+ edo pwsh -NoProfile -NonInteractive ./build.ps1 "${ps1opts[@]}"
}
src_install() {