summaryrefslogtreecommitdiff
path: root/app-shells
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/Manifest.gzbin7308 -> 7474 bytes
-rw-r--r--app-shells/fzy/Manifest3
-rw-r--r--app-shells/fzy/fzy-0.9.ebuild33
-rw-r--r--app-shells/fzy/metadata.xml27
-rw-r--r--app-shells/hstr/Manifest3
-rw-r--r--app-shells/hstr/files/hstr-1.24-tinfo.patch11
-rw-r--r--app-shells/hstr/hstr-1.24.ebuild1
7 files changed, 77 insertions, 1 deletions
diff --git a/app-shells/Manifest.gz b/app-shells/Manifest.gz
index d61268a78267..e067568ea5fc 100644
--- a/app-shells/Manifest.gz
+++ b/app-shells/Manifest.gz
Binary files differ
diff --git a/app-shells/fzy/Manifest b/app-shells/fzy/Manifest
new file mode 100644
index 000000000000..2b731f109efe
--- /dev/null
+++ b/app-shells/fzy/Manifest
@@ -0,0 +1,3 @@
+DIST fzy-0.9.tar.gz 42992 BLAKE2B ebc7e73e0387101da65896a4108705048bb72b01261ea86a0abeaee22fe4517ac54351d508bb79419b05a15aa9c93c5d815c34d15353d01c02381e5d342e75b7 SHA512 71a44bc3bbef3a2d82476a69b5c9e28753e760bbb8d453a9e44b57f34a79dd8ebcd510a869dfeae95f522ba6ccb4b8f10f79c081ce6bc6cfae9a41f4071fefc0
+EBUILD fzy-0.9.ebuild 737 BLAKE2B 92aa9818d33f9a1a03e2adff05ae44c815e500e2d35fc19af7d746f08637d990bd96a317411c6953adeb9bb269f185b6d76ffdfe0dcabcab2864ec3dc7b4e15f SHA512 6e130c3b7bc2f90fafd4f73add389bbb657967a793f95ac9348ae3ab461d13ce8f21c64316d2714d2a0dc12d9853849d39885103c1b46e816446484e4f30a7b3
+MISC metadata.xml 1003 BLAKE2B 9ac27e76694a7e5213431b0cda2b7824d0c30da29e9137537250c3bc53537216104b4c3fa602be4e1b9d68286f1ddb8b411510250a320a51f63dc2f0007e2399 SHA512 5970a188a0c270dda4c6dc13520daf7ebe4fbcb48cf19fd1c3ad5f708c480cb9ba26ccf181b8534246d556a23bfb5252dd48cd91b047164cea302fb593c91563
diff --git a/app-shells/fzy/fzy-0.9.ebuild b/app-shells/fzy/fzy-0.9.ebuild
new file mode 100644
index 000000000000..28bbf0fbf06b
--- /dev/null
+++ b/app-shells/fzy/fzy-0.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit savedconfig
+
+DESCRIPTION="Fuzzy text selector (interactive grep) for console"
+HOMEPAGE="https://github.com/jhawthorn/fzy"
+SRC_URI="https://github.com/jhawthorn/fzy/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ eapply_user
+ sed -i -e '/^CFLAGS/s/ -O3//' Makefile || die "sed failed"
+ restore_config config.h
+}
+
+src_install() {
+ local DOCS=( ALGORITHM.md CHANGELOG.md README.md )
+
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ exeinto /usr/share/fzy
+ doexe contrib/fzy-tmux
+ doexe contrib/fzy-dvtm
+ einstalldocs
+ save_config config.h
+}
diff --git a/app-shells/fzy/metadata.xml b/app-shells/fzy/metadata.xml
new file mode 100644
index 000000000000..e97ca2a7fe00
--- /dev/null
+++ b/app-shells/fzy/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ya@sysdump.net</email>
+ <name>Georgy Yakovlev</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>shell-tools@gentoo.org</email>
+ <name>Gentoo Shell Tools Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Fuzzy text selector (interactive grep) for console.
+ It can be used to filter any list:
+ files, command history, processes, hostnames, bookmarks, git commits, etc.
+ It's designed to be used both as an editor plugin and on the command line.
+ Rather than clearing the screen, fzy displays its interface directly below
+ the current cursor position, scrolling the screen if necessary.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">jhawthorn/fzy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/hstr/Manifest b/app-shells/hstr/Manifest
index 5b9781830aea..3892c2e16480 100644
--- a/app-shells/hstr/Manifest
+++ b/app-shells/hstr/Manifest
@@ -1,6 +1,7 @@
AUX hstr-1.23-tinfo.patch 481 BLAKE2B 3279671caf216d810c3fef490c5ae219906e59430dc15a850118bbafe49140f46fb1645be1c0a8a8977c795af018164027f928d4fcb0a664186c97f2b968edfb SHA512 64c1e0a5b2ee28354f85563472dd301a9e45eb568fe74c0d601765ee25095650320b8f853c95280f294f323eec6b7f9a155c2a09a5fde2e52568d2c9809c1e91
+AUX hstr-1.24-tinfo.patch 481 BLAKE2B 3279671caf216d810c3fef490c5ae219906e59430dc15a850118bbafe49140f46fb1645be1c0a8a8977c795af018164027f928d4fcb0a664186c97f2b968edfb SHA512 64c1e0a5b2ee28354f85563472dd301a9e45eb568fe74c0d601765ee25095650320b8f853c95280f294f323eec6b7f9a155c2a09a5fde2e52568d2c9809c1e91
DIST hstr-1.23.tar.gz 47239 BLAKE2B dec630f1e8161edc40544561dd85ea1c128a6704eeeaeb39eb6987bdc096a070c9e242b938bed01b80e208aadf08606518a007919d353f76ff1c36e7906aeabb SHA512 234c72587d0492d788b1c001b5e53f74820790a9ebe670e8abd28cd82fc7db65996d54160e675055be54cab110686838fe6e36dbefe0fbef9175613633bc5910
DIST hstr-1.24.tar.gz 47523 BLAKE2B 6e84ea6bd26cb0745f48e5f8701d4d956ae4b83ed825398fdc401fd0b7f13eb9874de62d438e71a57fa048a535a538504e7fabd7b4a698665a10a901e0a570e6 SHA512 fe522374e33150007c0bbe5d11d38e63c355519350f5777c8787aae62826553b61a358185994d196d015590649fb3accf75948e340233459409d594e51874658
EBUILD hstr-1.23.ebuild 631 BLAKE2B d3eb2ade2c30a1e61cc58349e52fe33d76ddb14ca490416aae276b106961287d79c1546b48ba8d56396ea84f95d741b1931b19516cc3e4a173398b644b75b99d SHA512 355201bac2ed090066c79e2c4d6d195510c28a18dd7105a0d23142724292221f2bdeb8f70de0db4ca6f2ae43e59969201110b00f4a461b49fe776f34d790042f
-EBUILD hstr-1.24.ebuild 590 BLAKE2B da2f711c59a6de9a7df26352289b14d60a3c08176c62a4b9dfb50c649fea996d8784fe045f48de2e4ffd0524163dc1a4fd36b6d73f5fe621a74a5941290427a7 SHA512 6528964c77fd4867b4d0f54afdc563325ca2b799bafcabebd4242c402e99fa5651ce347bd55756d7acfc5c68ec2828b92157fd4b2242a6913b4141857d6ff2d5
+EBUILD hstr-1.24.ebuild 633 BLAKE2B bbc75b9a1bd56c66ef62fab66bd760275695518e0a59b162d41525a78f6ff4bedb8022edc7276067c943c2d6eb283363377bbd7902f7d70dd30b92043a28c91d SHA512 b3e86724596618d75b6d8cd8dff17ec2d1111b1f3e3a2cd89a1934df1a0c6726894a6c78dd9e2b0d78d86f71d95017674fabc3ec59e66677f4a2d40b8bcf5308
MISC metadata.xml 453 BLAKE2B f0d991ae15d9b76c28a58f73be00cbb4824451019e9ef2858611681c4472c13cc4367166a130b3a313ac8ecafb859593610c52dab6c0cb7783ab079e31abeb27 SHA512 07997cef95d27c283b525f9a09d2762338c5bc8c2129904672cabf85e0d441ef7dc9b06608c0d38f0ae8d5d86e3fe8fc22bf8ebc7b29a81f8e9469436e62cf3e
diff --git a/app-shells/hstr/files/hstr-1.24-tinfo.patch b/app-shells/hstr/files/hstr-1.24-tinfo.patch
new file mode 100644
index 000000000000..85a4743c0e94
--- /dev/null
+++ b/app-shells/hstr/files/hstr-1.24-tinfo.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -76,7 +76,7 @@
+ AC_CHECK_LIB(m, cos, [], [AC_MSG_ERROR([Could not find m library])])
+ AC_CHECK_LIB(readline, using_history, [], [AC_MSG_ERROR([Could not find readline library])])
+ # ncurses might be linked in libtinfo
+-#AC_CHECK_LIB(tinfo, keypad, [], [AC_MSG_ERROR([Could not find tinfo library])])
++AC_SEARCH_LIBS(keypad, tinfo, [], [AC_MSG_ERROR([Could not find tinfo library])])
+
+ # Checks for header files.
+ AC_CHECK_HEADER(assert.h)
diff --git a/app-shells/hstr/hstr-1.24.ebuild b/app-shells/hstr/hstr-1.24.ebuild
index 0f8e9981f2a3..fc44e8039c0b 100644
--- a/app-shells/hstr/hstr-1.24.ebuild
+++ b/app-shells/hstr/hstr-1.24.ebuild
@@ -20,6 +20,7 @@ DEPEND="
virtual/pkgconfig"
DOCS=( CONFIGURATION.md README.md )
+PATCHES=( "${FILESDIR}/${P}-tinfo.patch" )
src_prepare() {
default