summaryrefslogtreecommitdiff
path: root/app-shells/yash/yash-2.56.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/yash/yash-2.56.1.ebuild')
-rw-r--r--app-shells/yash/yash-2.56.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-shells/yash/yash-2.56.1.ebuild b/app-shells/yash/yash-2.56.1.ebuild
new file mode 100644
index 000000000000..9084d796b0ba
--- /dev/null
+++ b/app-shells/yash/yash-2.56.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PLOCALES="en ja"
+
+inherit flag-o-matic plocale toolchain-funcs
+
+DESCRIPTION="Yash is a POSIX-compliant command line shell"
+HOMEPAGE="https://magicant.github.io/yash/"
+SRC_URI="https://github.com/magicant/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE="nls test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-libs/ncurses:=
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )
+ test? ( sys-apps/ed )"
+
+src_configure() {
+ append-cflags -std=c99
+
+ sh ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --exec-prefix="${EPREFIX}" \
+ $(use_enable nls) \
+ CC="$(tc-getCC)" \
+ LINGUAS="$(plocale_get_locales | sed "s/en/en@quot en@boldquot/")" \
+ || die
+}