summaryrefslogtreecommitdiff
path: root/app-shells/thefuck/thefuck-3.28.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/thefuck/thefuck-3.28.ebuild')
-rw-r--r--app-shells/thefuck/thefuck-3.28.ebuild18
1 files changed, 6 insertions, 12 deletions
diff --git a/app-shells/thefuck/thefuck-3.28.ebuild b/app-shells/thefuck/thefuck-3.28.ebuild
index d7199bc7ffe9..c55322df315f 100644
--- a/app-shells/thefuck/thefuck-3.28.ebuild
+++ b/app-shells/thefuck/thefuck-3.28.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
inherit distutils-r1
@@ -14,8 +14,6 @@ SRC_URI="https://github.com/nvbn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="
dev-python/psutil[${PYTHON_USEDEP}]
@@ -24,19 +22,15 @@ RDEPEND="
dev-python/colorama[${PYTHON_USEDEP}]
dev-python/pyte[${PYTHON_USEDEP}]"
DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
dev-python/pytest-mock[${PYTHON_USEDEP}]
- )"
+ )
+"
+
+distutils_enable_tests pytest
python_prepare_all() {
sed -i -e "/import pip/s/^/#/" -e "/pip.__version__/,+3 s/^/#/" setup.py || die
-
distutils-r1_python_prepare_all
}
-
-python_test() {
- py.test -vv || die
-}