summaryrefslogtreecommitdiff
path: root/app-shells/powerline/powerline-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/powerline/powerline-9999.ebuild')
-rw-r--r--app-shells/powerline/powerline-9999.ebuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/app-shells/powerline/powerline-9999.ebuild b/app-shells/powerline/powerline-9999.ebuild
index bee72318c1b8..5f68dc9da7f2 100644
--- a/app-shells/powerline/powerline-9999.ebuild
+++ b/app-shells/powerline/powerline-9999.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit distutils-r1
-DESCRIPTION="The ultimate statusline/prompt utility."
+DESCRIPTION="The ultimate statusline/prompt utility"
HOMEPAGE="https://github.com/powerline/powerline"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -15,14 +15,9 @@ if [[ ${PV} == 9999 ]]; then
S="${WORKDIR}/powerline-${PV}"
else
SRC_URI="mirror://pypi/${PN:0:1}/${PN}-status/${PN}-status-${PV}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
S="${WORKDIR}/${PN}-status-${PV}"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
fi
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""