summaryrefslogtreecommitdiff
path: root/app-shells/fzf/fzf-0.25.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/fzf/fzf-0.25.0.ebuild')
-rw-r--r--app-shells/fzf/fzf-0.25.0.ebuild106
1 files changed, 106 insertions, 0 deletions
diff --git a/app-shells/fzf/fzf-0.25.0.ebuild b/app-shells/fzf/fzf-0.25.0.ebuild
new file mode 100644
index 000000000000..5e56f7480e11
--- /dev/null
+++ b/app-shells/fzf/fzf-0.25.0.ebuild
@@ -0,0 +1,106 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="A general-purpose command-line fuzzy finder, written in GoLang"
+HOMEPAGE="https://github.com/junegunn/fzf"
+
+# For fancy versioning only. Bump on the next release!
+MY_GIT_REV=8c533e3
+
+EGO_SUM=(
+ "github.com/gdamore/encoding v1.0.0"
+ "github.com/gdamore/encoding v1.0.0/go.mod"
+ "github.com/gdamore/tcell v1.4.0"
+ "github.com/gdamore/tcell v1.4.0/go.mod"
+ "github.com/lucasb-eyer/go-colorful v1.0.3"
+ "github.com/lucasb-eyer/go-colorful v1.0.3/go.mod"
+ "github.com/mattn/go-isatty v0.0.12"
+ "github.com/mattn/go-isatty v0.0.12/go.mod"
+ "github.com/mattn/go-runewidth v0.0.7/go.mod"
+ "github.com/mattn/go-runewidth v0.0.9"
+ "github.com/mattn/go-runewidth v0.0.9/go.mod"
+ "github.com/mattn/go-shellwords v1.0.10"
+ "github.com/mattn/go-shellwords v1.0.10/go.mod"
+ "github.com/saracen/walker v0.1.1"
+ "github.com/saracen/walker v0.1.1/go.mod"
+ "golang.org/x/crypto v0.0.0-20190308221718-c2843e01d9a2"
+ "golang.org/x/crypto v0.0.0-20190308221718-c2843e01d9a2/go.mod"
+ "golang.org/x/crypto v0.0.0-20201016220609-9e8e0b390897"
+ "golang.org/x/crypto v0.0.0-20201016220609-9e8e0b390897/go.mod"
+ "golang.org/x/net v0.0.0-20190404232315-eb5bcb51f2a3/go.mod"
+ "golang.org/x/sync v0.0.0-20200317015054-43a5402ce75a/go.mod"
+ "golang.org/x/sync v0.0.0-20201020160332-67f06af15bc9"
+ "golang.org/x/sync v0.0.0-20201020160332-67f06af15bc9/go.mod"
+ "golang.org/x/sys v0.0.0-20190215142949-d0b11bdaac8a/go.mod"
+ "golang.org/x/sys v0.0.0-20190412213103-97732733099d/go.mod"
+ "golang.org/x/sys v0.0.0-20190626150813-e07cf5db2756"
+ "golang.org/x/sys v0.0.0-20190626150813-e07cf5db2756/go.mod"
+ "golang.org/x/sys v0.0.0-20200116001909-b77594299b42/go.mod"
+ "golang.org/x/sys v0.0.0-20201026173827-119d4633e4d1"
+ "golang.org/x/sys v0.0.0-20201026173827-119d4633e4d1/go.mod"
+ "golang.org/x/text v0.3.0"
+ "golang.org/x/text v0.3.0/go.mod"
+ "golang.org/x/text v0.3.3"
+ "golang.org/x/text v0.3.3/go.mod"
+ "golang.org/x/tools v0.0.0-20180917221912-90fa682c2a6e/go.mod"
+)
+
+go-module_set_globals
+
+SRC_URI="
+ https://github.com/junegunn/fzf/archive/${PV}.tar.gz -> ${P}.tar.gz
+ ${EGO_SUM_SRC_URI}
+"
+
+LICENSE="MIT BSD-with-disclosure"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ emake PREFIX="${EPREFIX}"/usr VERSION=${PV} REVISION=${MY_GIT_REV} bin/${PN}
+}
+
+src_install() {
+ dobin bin/${PN}
+ doman man/man1/${PN}.1
+
+ dobin bin/${PN}-tmux
+ doman man/man1/${PN}-tmux.1
+
+ insinto /usr/share/vim/vimfiles/plugin
+ doins plugin/${PN}.vim
+
+ insinto /usr/share/nvim/runtime/plugin
+ doins plugin/${PN}.vim
+
+ newbashcomp shell/completion.bash ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins shell/completion.zsh _${PN}
+
+ insinto /usr/share/fzf
+ doins shell/key-bindings.bash
+ doins shell/key-bindings.fish
+ doins shell/key-bindings.zsh
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "To add fzf support to your shell, make sure to use the right file"
+ elog "from /usr/share/fzf."
+ elog
+ elog "For bash, add the following line to ~/.bashrc:"
+ elog
+ elog " # source /usr/share/bash-completion/completions/fzf"
+ elog " # source /usr/share/fzf/key-bindings.bash"
+ elog
+ elog "Plugins for Vim and Neovim are installed to respective directories"
+ elog "and will work out of the box."
+ elog
+ elog "For fzf support in tmux see fzf-tmux(1)."
+ fi
+}