summaryrefslogtreecommitdiff
path: root/app-shells/dash/dash-0.5.10.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/dash/dash-0.5.10.2.ebuild')
-rw-r--r--app-shells/dash/dash-0.5.10.2.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/app-shells/dash/dash-0.5.10.2.ebuild b/app-shells/dash/dash-0.5.10.2.ebuild
index d51383e2eb19..4935f47043ac 100644
--- a/app-shells/dash/dash-0.5.10.2.ebuild
+++ b/app-shells/dash/dash-0.5.10.2.ebuild
@@ -55,6 +55,9 @@ src_configure() {
# don't redefine stat on Solaris
if [[ ${CHOST} == *-solaris* ]] ; then
export ac_cv_func_stat64=yes
+
+ # if your headers strictly adhere to POSIX, you'll need this too
+ [[ ${CHOST##*solaris2.} -le 10 ]] && append-cppflags -DNAME_MAX=255
fi
append-cppflags -DJOBS=$(usex libedit 1 0)
use static && append-ldflags -static