summaryrefslogtreecommitdiff
path: root/app-shells/bash/bash-5.1_p16.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/bash/bash-5.1_p16.ebuild')
-rw-r--r--app-shells/bash/bash-5.1_p16.ebuild24
1 files changed, 21 insertions, 3 deletions
diff --git a/app-shells/bash/bash-5.1_p16.ebuild b/app-shells/bash/bash-5.1_p16.ebuild
index a274960e97fe..43292ec1f762 100644
--- a/app-shells/bash/bash-5.1_p16.ebuild
+++ b/app-shells/bash/bash-5.1_p16.ebuild
@@ -6,6 +6,10 @@ EAPI=7
VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/chetramey.asc
inherit flag-o-matic toolchain-funcs prefix verify-sig
+# Uncomment if we have a patchset
+GENTOO_PATCH_DEV="sam"
+GENTOO_PATCH_VER="${PV}"
+
# Official patchlevel
# See ftp://ftp.cwru.edu/pub/bash/bash-5.1-patches/
PLEVEL="${PV##*_p}"
@@ -48,6 +52,10 @@ else
SRC_URI+=" verify-sig? ( ftp://ftp.cwru.edu/pub/bash/${MY_P}.tar.gz.sig )"
fi
+if [[ -n ${GENTOO_PATCH_VER} ]] ; then
+ SRC_URI+=" https://dev.gentoo.org/~${GENTOO_PATCH_DEV}/distfiles/${CATEGORY}/${PN}/${PN}-${GENTOO_PATCH_VER}-patches.tar.xz"
+fi
+
LICENSE="GPL-3"
SLOT="0"
[[ "${PV}" == *_rc* ]] || \
@@ -70,7 +78,7 @@ S="${WORKDIR}/${MY_P}"
PATCHES=(
# Patches from Chet sent to bashbug ml
- "${FILESDIR}"/${PN}-5.0-syslog-history-extern.patch
+ "${WORKDIR}"/${PN}-${GENTOO_PATCH_VER}-patches/${PN}-5.0-syslog-history-extern.patch
)
pkg_setup() {
@@ -88,9 +96,19 @@ pkg_setup() {
}
src_unpack() {
- verify-sig_src_unpack
+ if [[ ${PV} == 9999 ]] ; then
+ git-r3_src_unpack
+ else
+ if use verify-sig ; then
+ verify-sig_verify_detached "${DISTDIR}"/${MY_P}.tar.gz{,.sig}
+ fi
+
+ unpack ${MY_P}.tar.gz
- unpack ${MY_P}.tar.gz
+ if [[ -n ${GENTOO_PATCH_VER} ]] ; then
+ unpack ${PN}-${GENTOO_PATCH_VER}-patches.tar.xz
+ fi
+ fi
}
src_prepare() {