summaryrefslogtreecommitdiff
path: root/app-shells/bash/bash-5.1_p16.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/bash/bash-5.1_p16.ebuild')
-rw-r--r--app-shells/bash/bash-5.1_p16.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/app-shells/bash/bash-5.1_p16.ebuild b/app-shells/bash/bash-5.1_p16.ebuild
index 210c50044a0b..04915ee41df9 100644
--- a/app-shells/bash/bash-5.1_p16.ebuild
+++ b/app-shells/bash/bash-5.1_p16.ebuild
@@ -3,7 +3,8 @@
EAPI=7
-inherit flag-o-matic toolchain-funcs prefix
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/chetramey.asc
+inherit flag-o-matic toolchain-funcs prefix verify-sig
# Official patchlevel
# See ftp://ftp.cwru.edu/pub/bash/bash-5.1-patches/
@@ -29,6 +30,7 @@ patches() {
local u
for u in mirror://gnu/${pn} ftp://ftp.cwru.edu/pub/bash ; do
printf "${u}/${pn}-${pv}-patches/%s " "$@"
+ printf "${u}/${pn}-${pv}-patches/%s.sig " "$@"
done
fi
}
@@ -37,11 +39,13 @@ patches() {
READLINE_VER="8.1"
DESCRIPTION="The standard GNU Bourne again shell"
-HOMEPAGE="http://tiswww.case.edu/php/chet/bash/bashtop.html"
+HOMEPAGE="https://tiswww.case.edu/php/chet/bash/bashtop.html"
if is_release ; then
SRC_URI="mirror://gnu/bash/${MY_P}.tar.gz $(patches)"
+ SRC_URI+=" verify-sig? ( mirror://gnu/bash/${MY_P}.tar.gz.sig )"
else
SRC_URI="ftp://ftp.cwru.edu/pub/bash/${MY_P}.tar.gz"
+ SRC_URI+=" verify-sig? ( ftp://ftp.cwru.edu/pub/bash/${MY_P}.tar.gz.sig )"
fi
LICENSE="GPL-3"
@@ -59,7 +63,8 @@ RDEPEND="
${DEPEND}
"
# We only need yacc when the .y files get patched (bash42-005, bash51-011)
-BDEPEND="virtual/yacc"
+BDEPEND="virtual/yacc
+ verify-sig? ( sec-keys/openpgp-keys-chetramey )"
S="${WORKDIR}/${MY_P}"
@@ -83,6 +88,8 @@ pkg_setup() {
}
src_unpack() {
+ verify-sig_src_unpack
+
unpack ${MY_P}.tar.gz
}