summaryrefslogtreecommitdiff
path: root/app-portage
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/Manifest.gzbin9251 -> 9412 bytes
-rw-r--r--app-portage/elsw/Manifest4
-rw-r--r--app-portage/elsw/elsw-0.0.0.ebuild25
-rw-r--r--app-portage/elsw/elsw-9999.ebuild25
-rw-r--r--app-portage/elsw/metadata.xml18
-rw-r--r--app-portage/gemato/Manifest2
-rw-r--r--app-portage/gemato/gemato-18.0.ebuild2
-rw-r--r--app-portage/genlop/Manifest2
-rw-r--r--app-portage/genlop/metadata.xml2
-rw-r--r--app-portage/iwdevtools/Manifest2
-rw-r--r--app-portage/iwdevtools/iwdevtools-0.12.3.ebuild65
11 files changed, 143 insertions, 4 deletions
diff --git a/app-portage/Manifest.gz b/app-portage/Manifest.gz
index 913f1ff23c0a..8b6e437190e0 100644
--- a/app-portage/Manifest.gz
+++ b/app-portage/Manifest.gz
Binary files differ
diff --git a/app-portage/elsw/Manifest b/app-portage/elsw/Manifest
new file mode 100644
index 000000000000..a830293aa91c
--- /dev/null
+++ b/app-portage/elsw/Manifest
@@ -0,0 +1,4 @@
+DIST elsw-0.0.0.tar.gz 9857 BLAKE2B 8948b41bd163c393c735f08e94440905cca93078d8eefbb7b7136542a54a3139baaa4b40725667239fd249d9f569ececaf13631162502e3f58e5b288fdf1ae4f SHA512 9e0323ebdc01e6e2af2e021f2bfae2f977567697600167860de7a95d8c80e3119214524a6514114747bdebd269bf68d14f2e0369765d7fea62ae0adaf060e94c
+EBUILD elsw-0.0.0.ebuild 554 BLAKE2B 7e0c934e81e7f1ae57c2afe6bff615133dcc7fa84797e69ecdbbdfdf2a21b6054a24e32569a3a7b1adc5b8b2e9738ddf02e79ca0035171da9ab5fee6d5fa324e SHA512 e60cf64dcc0ec5266edfda37c3cb82f2fc8de9d90573d38a714991ca168166cbe3ff275f0619cc67038f6408e9a5b640b9b405dff796951eee3d81d3441fc504
+EBUILD elsw-9999.ebuild 554 BLAKE2B 7e0c934e81e7f1ae57c2afe6bff615133dcc7fa84797e69ecdbbdfdf2a21b6054a24e32569a3a7b1adc5b8b2e9738ddf02e79ca0035171da9ab5fee6d5fa324e SHA512 e60cf64dcc0ec5266edfda37c3cb82f2fc8de9d90573d38a714991ca168166cbe3ff275f0619cc67038f6408e9a5b640b9b405dff796951eee3d81d3441fc504
+MISC metadata.xml 569 BLAKE2B 31216d894073274a09af9c69f3d1696ca5e2003eae2740888574d1c9d5b742996719208d9910562f3cc3d3599c867449fd28a444fabb79f2b77ec0f3b80615c5 SHA512 c90f29a651ca6b48df95caefcd9b5fc38c91c6e3254ecbccc0cf5055cb30fc6f0d3fb524a8f7f56afb69d91517032dcb04b54456381ca7f2aa8b324c701c90a0
diff --git a/app-portage/elsw/elsw-0.0.0.ebuild b/app-portage/elsw/elsw-0.0.0.ebuild
new file mode 100644
index 000000000000..521be8e3f793
--- /dev/null
+++ b/app-portage/elsw/elsw-0.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tool providing a nice way to view the Portage world file"
+HOMEPAGE="https://gitlab.com/xgqt/python-elsw/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/xgqt/python-${PN}.git"
+else
+ SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+DOCS=( README.md )
diff --git a/app-portage/elsw/elsw-9999.ebuild b/app-portage/elsw/elsw-9999.ebuild
new file mode 100644
index 000000000000..521be8e3f793
--- /dev/null
+++ b/app-portage/elsw/elsw-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tool providing a nice way to view the Portage world file"
+HOMEPAGE="https://gitlab.com/xgqt/python-elsw/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/xgqt/python-${PN}.git"
+else
+ SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+DOCS=( README.md )
diff --git a/app-portage/elsw/metadata.xml b/app-portage/elsw/metadata.xml
new file mode 100644
index 000000000000..a434c9d8d886
--- /dev/null
+++ b/app-portage/elsw/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>xgqt@riseup.net</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <bugs-to>https://gitlab.com/xgqt/python-elsw/-/issues/</bugs-to>
+ <remote-id type="gitlab">xgqt/python-elsw</remote-id>
+ <remote-id type="pypi">elsw</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-portage/gemato/Manifest b/app-portage/gemato/Manifest
index 0f1f55e2c08a..d4a04f308761 100644
--- a/app-portage/gemato/Manifest
+++ b/app-portage/gemato/Manifest
@@ -1,6 +1,6 @@
DIST gemato-17.0.tar.gz 83991 BLAKE2B 7a01b8ecb9e3540c698b7d57e5b6ba0961d42e7edd51e7b422d0e3d89088230633f3402b19168b3ccb772f028a3f669b324e76fa84f1918afa1c92c728942f14 SHA512 22066939ccab081c5d2bd52eab587aed0893b11cac40256a2e08a9a2f14e20320acaffd3414c4111bf27db15aca6d76a3856b6a3d8d5019fd649a2f7e07e3265
DIST gemato-18.0.gh.tar.gz 85575 BLAKE2B a923c3d7731b70798d9baf7e9faf0884723bb5e15b4e24712ecd807b79e8ca7e1532f894cf6a3b675bd72419eac41f1481fcd34fb21c9989871141819b036fa2 SHA512 9491579c3d80f9b500da2a50aed173641d049293e37f11c3c06616ff49949cae16dfd274ae79dcacca4bb4c27baf30a5f3900f45fc3dfb2b9fb5da8139db63e3
EBUILD gemato-17.0.ebuild 1031 BLAKE2B 6b390754cbbedb4d665b98ef29548b18e65b9e1721525b1f7dce2055c909288facc6439aa7f3948475227d84d1da50bc1de5d9cc62065d332af70a6628402776 SHA512 a6237288c3327e58027bef5821bccc0edbc1a4f37b4051b4a4b829b488dc2b3d9bf300420d66f372c67e159bb4d132153f2858bb2f61255de925ad76bf12ada9
-EBUILD gemato-18.0.ebuild 1114 BLAKE2B c3d5d8f9b1a8034c7799c6f2d413738201cc70f455c101e1647679eb56da50400844277fa68baf58e3a4975d69ae6fbb6dd4bbdda544c55a389b68e40d112f28 SHA512 a8cf5b5443eadf1742877fbc9acf9c5a21b584227d9f8ee1066cf14491044768387859f914ea3bae352ad3a4c6d8d473965178549b5aa7ee9a7219d24b93b35a
+EBUILD gemato-18.0.ebuild 1106 BLAKE2B 66ae2706dac6276b75fdc1a102a01d0ddd1d496427956f34eb12e5b2dde1f39337318f0eec7882b059d3927244c46a610e26d6731662854d52a72681c3c6beaa SHA512 42b6bfad2c8acba3adbf0b47c7e36743f48aa44e635b6d97887a10dc4c7da34028cb7c6643ec03bf6522907309294a018803b3c0b5fef4d78d2985128a390d88
EBUILD gemato-9999.ebuild 957 BLAKE2B 361e57ab1a563727eaaec872d9c427a9935ab5c2863996ae72869a8b6817824f81755ad7fb033ac782a71b09bfdb6c4e8e6290645b3d904647836b4705558ae3 SHA512 9383726e8c7be060b8537477733eb93cece38ed04b375455db0cb907d10647018f9a6021f6fd1e4388f66f6f4c6c80ff192c2e5b7f1e7132e63d99410ea39258
MISC metadata.xml 805 BLAKE2B 039ea9810f2c76d69bdfa5823994be4aa012746032a8c1e01aa7a11a05e4c4e0b278ff5633a519ad8e7398f3328480128c7d9d621dc7911d1ed1d827175c7dac SHA512 1fb3ec26e41b912cdd6ca289acadc50f2d73adf4e9cf9cae40c197ecfa10c19e17716e7153c9be82684ae35580d03ae296586b062f2d54641ab2738c338f1626
diff --git a/app-portage/gemato/gemato-18.0.ebuild b/app-portage/gemato/gemato-18.0.ebuild
index 7e02cc9bba9d..b9fde110b002 100644
--- a/app-portage/gemato/gemato-18.0.ebuild
+++ b/app-portage/gemato/gemato-18.0.ebuild
@@ -21,7 +21,7 @@ SRC_URI="
LICENSE="BSD-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux"
IUSE="+gpg pretty-log tools"
RDEPEND="
diff --git a/app-portage/genlop/Manifest b/app-portage/genlop/Manifest
index e920f2235c7c..497451fae6d0 100644
--- a/app-portage/genlop/Manifest
+++ b/app-portage/genlop/Manifest
@@ -3,4 +3,4 @@ AUX genlop-0.30.10-sync.patch 671 BLAKE2B 21f73d44ac404fc94462e8cba765baa6f88c1d
DIST genlop-0.30.10.tar.gz 20872 BLAKE2B e06088678598464c67b78cf10a7472d7bf7b22d69c85fc072064b7a90fe57e2015fddba30edaa85574381cd59367b81c7bf514c269d5dc186fbcc367bba0cca4 SHA512 eab59d7dc012fbbdbe7de509deba66e6c7d0c5a37064e79c25a37c64becc259ee5206194615b60b3363022fa59e458356547edca307ceb4e19eeeaf4b146c593
EBUILD genlop-0.30.10-r2.ebuild 755 BLAKE2B 319862c8d826e6d32a5e4b38a72845632a45cf6d3afff42f2d83a2dedc8e03e46a927bb7905a2c863a4efce15831be936a6527d7649e90ca67ff18f915471009 SHA512 1bfc54adf7d5acd4719595f35d2df66bc6c7b6d12c15e12379b32eb427bd8514b99e07943f8dddf2fdc8389918abd316a32952d00ef77064fcf76635233fb292
EBUILD genlop-9999.ebuild 529 BLAKE2B 5657b64c97a6b71c1a5a7170489d1950460f20d2088deb140ce43a35a6b492706f3524b32f299ebe2366648a51b3d2faf7d32a9686466d327bf4c64dc597c5ea SHA512 76ecf847069e02b319049ee1557de0cdd6b9756ea8dbc820081832387659b364650318b8538fd64161f3259e7354894958f373a4dbf3863c1eeb902f2e102b1d
-MISC metadata.xml 378 BLAKE2B d111f1f1120ef7b16841af32d2ba15f322c190e31c697ff4e80d5edfd19a1732b13666e6f00c6c1e1deae255773ed564c0694b88cd405e3e9074ee31c17312db SHA512 30008fa17e957d098023ceaa3b9c51dd413e54f828ee97e8dd093d477a8517517d7257c000b0b07a5943610dd3b5fdd04522328cc9c77e89523c21b197ce722a
+MISC metadata.xml 379 BLAKE2B 9016a27c85cfffcec5b7e62d036ab56a356949e19a16aff7a4020e357b8ba4808e55b5780b6998da2b7101a4428fdbafdb1543b4c9049e61f396f6ebe93eabe8 SHA512 88e0b98cece7b56416d8eb23826297108fcade41aa0872cd39bf3f16bcdfae0455b963a26ecd4f07c16cf4eaff421848b7096239cb0dc81b98403883bddc8aa4
diff --git a/app-portage/genlop/metadata.xml b/app-portage/genlop/metadata.xml
index 190c6d6e0276..128ec12874f7 100644
--- a/app-portage/genlop/metadata.xml
+++ b/app-portage/genlop/metadata.xml
@@ -5,7 +5,7 @@
<email>tools-portage@gentoo.org</email>
<name>Gentoo Portage tools team</name>
</maintainer>
-<maintainer type="project">
+ <maintainer type="project">
<email>perl@gentoo.org</email>
<name>Gentoo Perl Project</name>
</maintainer>
diff --git a/app-portage/iwdevtools/Manifest b/app-portage/iwdevtools/Manifest
index 673e4f220a48..0c463062118e 100644
--- a/app-portage/iwdevtools/Manifest
+++ b/app-portage/iwdevtools/Manifest
@@ -1,4 +1,6 @@
DIST iwdevtools-0.12.2.tar.gz 89451 BLAKE2B 51d167480f03ddfcbc2b5c4bdee2423c3d28243f99cb4b3f98db51cf2695b1acac00c8c630a5db93cffe3bef30ce2797dc1464be95ecfcaffc7478a218968a4c SHA512 7191a14a9c8707d91ae86c4ae4e1cab069e0b6c5f785d34ba192a34acfce9dbd0baec07a04715f0d03841166a514a6bef4149ddabd15adc6291003568fc78d37
+DIST iwdevtools-0.12.3.tar.gz 89745 BLAKE2B 7d52bd59fcc98cff28873dd8d7737b1e75a99111ea27dac6803d2a14975eb04dc5be88a03e6efd46eef6662828453fc7c53afc9c920d82e74b44fd1e837e58df SHA512 f2efdce89350f85d2c77c7df9fa5fde62ac2923b5cc36eedd4c6ce507fbbe12f915e138a16c8b6b360f093057118a274844c112158ce01bb3f456a415b222216
EBUILD iwdevtools-0.12.2.ebuild 1927 BLAKE2B 0f1b452bf21689484a2092d7e52e443bcfdb6f469fb60e3c82c47f1030bb70f4c8c4a4e0d4802191668019b0aa7cc8e0d8249fb76a16e164c26451bc4a384757 SHA512 e7cf042f89d472114f9de24602d3d1b97fd8b6c089f59616b34fc5b19927379cd69615c77b970139aef2c7ec6cedc6fb256d00550d646fa8407883f264159910
+EBUILD iwdevtools-0.12.3.ebuild 1927 BLAKE2B e092ed1ba8b5d3e2e31622aa4b54417889f60fe8f5b2f9674699a4c847f35b593d53e0b6df047643e3be1cd55f21c9d2f5c1ece5fbc8a4140e9b27e2d45bf8a3 SHA512 f986ee0e61d226609d977cacb079861ba8dd1d5f5eb65e8f7862aff1a43eea23ff995a534b714ee5ffbce3e80d08e0f3ee4befae0603c9d662704485890a253b
EBUILD iwdevtools-9999.ebuild 1826 BLAKE2B 3374f5d939144190c7f8aefd57fd72cffa0f68e310fc08f5961d5cd945f2665b6a613feca445f9bd33a4c468b0cd33b267d87e52e690feef6fd4360a7c15ecf9 SHA512 e2609aeac7bb0e367c111e2ec1c798c5df8ffd85032aee29ed2837e0379032651ee10c58f26d148cce99564a176e4eca9c676d4e5584e8c51ff3d8bac030aa72
MISC metadata.xml 354 BLAKE2B 752c8fbf18967fb380f0f5d460396222f5fea3f0c7b9ed960ff0dbe62a9a505a2d07c45750aaa55285d11169e01f5e83b82eb278b12fbc5e9c43353c0a5fc9ed SHA512 d8e5866d89b7f05a5a8cd8cc464083d3d096b4c03f8a83e9314dcf45e57c25369bf8a3bc725aed3b8db9f3f86e76bad358bfa58f1eca70f7ec0bf3d31286c2c3
diff --git a/app-portage/iwdevtools/iwdevtools-0.12.3.ebuild b/app-portage/iwdevtools/iwdevtools-0.12.3.ebuild
new file mode 100644
index 000000000000..ad9fe2c7e81b
--- /dev/null
+++ b/app-portage/iwdevtools/iwdevtools-0.12.3.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature
+
+DESCRIPTION="Small tools to aid with Gentoo development, primarily intended for QA"
+HOMEPAGE="https://github.com/ionenwks/iwdevtools"
+SRC_URI="https://github.com/ionenwks/iwdevtools/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv sparc x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-misc/pax-utils
+ app-portage/portage-utils
+ >=app-shells/bash-5.1
+ dev-libs/libxml2:2
+ sys-apps/coreutils
+ sys-apps/diffutils
+ sys-apps/file
+ sys-apps/portage
+ || ( sys-apps/util-linux app-misc/getopt )"
+BDEPEND="
+ sys-apps/help2man
+ || ( sys-apps/util-linux app-misc/getopt )
+ test? ( ${RDEPEND} )"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir=${PF}
+ -Deprefix="${EPREFIX}"
+ -Dshellcheck=false
+ $(meson_use test)
+ )
+
+ has_version sys-apps/util-linux || emesonargs+=( -Dgetopt=getopt-long )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ optfeature "detecting potential ABI issues using abidiff" dev-util/libabigail
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Optional portage integration relies on using /etc/portage/bashrc."
+ elog "The example bashrc can be used as-is if not already using one:"
+ elog
+ elog " ln -s ../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
+ elog
+ elog "Otherwise, inspect the tools' --help output and the example to integrate"
+ elog "(if not defining the same phase functions, the example can be sourced)."
+ elog
+ elog "Note that \`eqawarn\` is used for portage output by default. QA messages"
+ elog "aren't logged / shown post-emerge unless e.g. in /etc/portage/make.conf:"
+ elog
+ elog ' PORTAGE_ELOG_CLASSES="${PORTAGE_ELOG_CLASSES} qa"'
+ elog
+ elog "See ${EROOT}/usr/share/doc/${PF}/README.rst* for information on tools."
+ fi
+}