summaryrefslogtreecommitdiff
path: root/app-portage/ufed/ufed-0.96.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/ufed/ufed-0.96.ebuild')
-rw-r--r--app-portage/ufed/ufed-0.96.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/app-portage/ufed/ufed-0.96.ebuild b/app-portage/ufed/ufed-0.96.ebuild
index 64a6a2cd5e43..5d53c39463df 100644
--- a/app-portage/ufed/ufed-0.96.ebuild
+++ b/app-portage/ufed/ufed-0.96.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -11,7 +11,7 @@ else
KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
fi
-inherit autotools out-of-source
+inherit autotools flag-o-matic out-of-source
DESCRIPTION="Gentoo Linux USE flags editor"
HOMEPAGE="https://wiki.gentoo.org/wiki/Ufed"
@@ -35,3 +35,11 @@ src_prepare() {
eautoreconf
}
+
+my_src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/854864
+ filter-lto
+
+ default
+}