summaryrefslogtreecommitdiff
path: root/app-portage/no-distcc-env/no-distcc-env-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/no-distcc-env/no-distcc-env-9999.ebuild')
-rw-r--r--app-portage/no-distcc-env/no-distcc-env-9999.ebuild20
1 files changed, 5 insertions, 15 deletions
diff --git a/app-portage/no-distcc-env/no-distcc-env-9999.ebuild b/app-portage/no-distcc-env/no-distcc-env-9999.ebuild
index 40d847edebb2..dbbeea27910c 100644
--- a/app-portage/no-distcc-env/no-distcc-env-9999.ebuild
+++ b/app-portage/no-distcc-env/no-distcc-env-9999.ebuild
@@ -1,33 +1,23 @@
-# Copyright 2019-2021 Gentoo Authors
+# Copyright 2019-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/${PN}.git"
-if [[ ${PV} = 9999* ]]; then
+if [[ ${PV} == 9999* ]]; then
GIT_ECLASS="git-r3"
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
fi
inherit ${GIT_ECLASS}
DESCRIPTION="package.env files to disable distcc on a per-package basis"
HOMEPAGE="https://gitweb.gentoo.org/proj/no-distcc-env.git/"
-if [[ ${PV} = 9999* ]]; then
- SRC_URI=""
-else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
- SRC_URI="https://github.com/anholt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-fi
LICENSE="public-domain"
SLOT="0"
-IUSE=""
-
-src_unpack() {
- default
- [[ ${PV} = 9999* ]] && git-r3_src_unpack
-}
src_install() {
insinto /etc/portage