summaryrefslogtreecommitdiff
path: root/app-portage/gs-elpa/gs-elpa-0.2.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/gs-elpa/gs-elpa-0.2.1-r1.ebuild')
-rw-r--r--app-portage/gs-elpa/gs-elpa-0.2.1-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-portage/gs-elpa/gs-elpa-0.2.1-r1.ebuild b/app-portage/gs-elpa/gs-elpa-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..71cb86fa6080
--- /dev/null
+++ b/app-portage/gs-elpa/gs-elpa-0.2.1-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="g-sorcery backend for elisp packages"
+HOMEPAGE="https://gitweb.gentoo.org/proj/gs-elpa.git
+ https://github.com/jauhien/gs-elpa"
+SRC_URI="https://gitweb.gentoo.org/proj/gs-elpa.git/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-2" # v2 only
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="app-portage/g-sorcery[${PYTHON_USEDEP}]
+ dev-python/sexpdata[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman docs/*.8
+}