summaryrefslogtreecommitdiff
path: root/app-portage/golop/golop-0.2.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/golop/golop-0.2.1-r1.ebuild')
-rw-r--r--app-portage/golop/golop-0.2.1-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-portage/golop/golop-0.2.1-r1.ebuild b/app-portage/golop/golop-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..ce8d84d8a050
--- /dev/null
+++ b/app-portage/golop/golop-0.2.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="A pure Go re-implementation of genlop"
+HOMEPAGE="https://github.com/klausman/golop"
+SRC_URI="https://github.com/klausman/golop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+src_compile() {
+ ego build -v -o ${PN}
+}
+
+src_install() {
+ dobin ${PN}
+
+ local DOCS=( README.md )
+ einstalldocs
+}