summaryrefslogtreecommitdiff
path: root/app-portage/gentoopm/gentoopm-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/gentoopm/gentoopm-9999.ebuild')
-rw-r--r--app-portage/gentoopm/gentoopm-9999.ebuild15
1 files changed, 5 insertions, 10 deletions
diff --git a/app-portage/gentoopm/gentoopm-9999.ebuild b/app-portage/gentoopm/gentoopm-9999.ebuild
index 840415f2aa12..f3f382633170 100644
--- a/app-portage/gentoopm/gentoopm-9999.ebuild
+++ b/app-portage/gentoopm/gentoopm-9999.ebuild
@@ -1,22 +1,19 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-DISTUTILS_USE_SETUPTOOLS=no
+DISTUTILS_USE_PEP517=flit
PYTHON_COMPAT=( python3_{8..10} )
-EGIT_REPO_URI="https://github.com/mgorny/gentoopm.git"
inherit distutils-r1 git-r3
DESCRIPTION="A common interface to Gentoo package managers"
HOMEPAGE="https://github.com/mgorny/gentoopm/"
-SRC_URI=""
+EGIT_REPO_URI="https://github.com/mgorny/gentoopm.git"
LICENSE="BSD-2"
SLOT="0"
-KEYWORDS=""
-IUSE=""
RDEPEND="
|| (
@@ -24,6 +21,4 @@ RDEPEND="
>=sys-apps/portage-2.1.10.3[${PYTHON_USEDEP}] )"
PDEPEND="app-eselect/eselect-package-manager"
-python_test() {
- esetup.py test
-}
+distutils_enable_tests pytest