summaryrefslogtreecommitdiff
path: root/app-portage/gentoolkit/gentoolkit-0.5.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/gentoolkit/gentoolkit-0.5.0-r2.ebuild')
-rw-r--r--app-portage/gentoolkit/gentoolkit-0.5.0-r2.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/app-portage/gentoolkit/gentoolkit-0.5.0-r2.ebuild b/app-portage/gentoolkit/gentoolkit-0.5.0-r2.ebuild
index be4445b5f1de..3a6ded107004 100644
--- a/app-portage/gentoolkit/gentoolkit-0.5.0-r2.ebuild
+++ b/app-portage/gentoolkit/gentoolkit-0.5.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,7 +17,7 @@ LICENSE="GPL-2"
SLOT="0"
IUSE=""
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
DEPEND="
sys-apps/portage[${PYTHON_USEDEP}]"
@@ -37,6 +37,13 @@ python_prepare_all() {
echo VERSION="${PVR}" "${PYTHON}" setup.py set_version
VERSION="${PVR}" "${PYTHON}" setup.py set_version
distutils-r1_python_prepare_all
+
+ if use prefix-guest ; then
+ # use correct repo name, bug #632223
+ sed -i \
+ -e "/load_profile_data/s/repo='gentoo'/repo='gentoo_prefix'/" \
+ pym/gentoolkit/profile.py || die
+ fi
}
pkg_preinst() {