summaryrefslogtreecommitdiff
path: root/app-portage/gemato/gemato-20.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/gemato/gemato-20.2.ebuild')
-rw-r--r--app-portage/gemato/gemato-20.2.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/app-portage/gemato/gemato-20.2.ebuild b/app-portage/gemato/gemato-20.2.ebuild
deleted file mode 100644
index 9ecc67eae748..000000000000
--- a/app-portage/gemato/gemato-20.2.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-PYTHON_REQ_USE='threads(+)'
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Stand-alone Manifest generation & verification tool"
-HOMEPAGE="
- https://github.com/projg2/gemato/
- https://pypi.org/project/gemato/
-"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="+gpg pretty-log tools"
-
-RDEPEND="
- gpg? (
- >=app-crypt/gnupg-2.2.20-r1
- dev-python/requests[${PYTHON_USEDEP}]
- )
- pretty-log? (
- dev-python/rich[${PYTHON_USEDEP}]
- )
-"
-BDEPEND="
- test? (
- >=app-crypt/gnupg-2.2.20-r1
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use tools; then
- exeinto /usr/share/gemato
- doexe utils/*.{bash,py}
- fi
-}