summaryrefslogtreecommitdiff
path: root/app-portage/g-cpan/g-cpan-0.16.9-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/g-cpan/g-cpan-0.16.9-r1.ebuild')
-rw-r--r--app-portage/g-cpan/g-cpan-0.16.9-r1.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/app-portage/g-cpan/g-cpan-0.16.9-r1.ebuild b/app-portage/g-cpan/g-cpan-0.16.9-r1.ebuild
index 97bac08d3294..8bf683d29b85 100644
--- a/app-portage/g-cpan/g-cpan-0.16.9-r1.ebuild
+++ b/app-portage/g-cpan/g-cpan-0.16.9-r1.ebuild
@@ -1,16 +1,17 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit perl-module
+
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/gentoo-perl/g-cpan.git"
inherit git-r3
SRC_URI=""
else
SRC_URI="https://github.com/gentoo-perl/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86"
+ KEYWORDS="~alpha amd64 arm hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86"
fi
DESCRIPTION="Autogenerate and install ebuilds for CPAN modules"
@@ -41,7 +42,11 @@ DEPEND="${COMMONDEPEND}
src_install() {
perl-module_src_install
- diropts -m0775 -o portage -g portage
+ if ! use prefix; then
+ diropts -m0775 -o portage -g portage
+ else
+ diropts -m0775
+ fi
dodir "/var/tmp/g-cpan"
dodir "/var/log/g-cpan"
keepdir "/var/log/g-cpan"