summaryrefslogtreecommitdiff
path: root/app-portage/flaggie/flaggie-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/flaggie/flaggie-9999.ebuild')
-rw-r--r--app-portage/flaggie/flaggie-9999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-portage/flaggie/flaggie-9999.ebuild b/app-portage/flaggie/flaggie-9999.ebuild
new file mode 100644
index 000000000000..60d5f61f5398
--- /dev/null
+++ b/app-portage/flaggie/flaggie-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+EGIT_REPO_URI="https://github.com/mgorny/flaggie.git"
+inherit bash-completion-r1 distutils-r1 git-r3
+
+DESCRIPTION="A smart CLI mangler for package.* files"
+HOMEPAGE="https://github.com/mgorny/flaggie/"
+SRC_URI=""
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="sys-apps/portage[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ newbashcomp contrib/bash-completion/${PN}.bash-completion ${PN}
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ ewarn "Please note that flaggie creates backups of your package.* files"
+ ewarn "before performing each change through appending a single '~'."
+ ewarn "If you'd like to keep your own backup of them, please use another"
+ ewarn "naming scheme (or even better some VCS)."
+ if ! has_version app-shells/gentoo-bashcomp; then
+ elog
+ elog "If you want to use bash-completion, you need to install:"
+ elog " app-shells/gentoo-bashcomp"
+ fi
+}