summaryrefslogtreecommitdiff
path: root/app-portage/esearch/esearch-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/esearch/esearch-9999.ebuild')
-rw-r--r--app-portage/esearch/esearch-9999.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/app-portage/esearch/esearch-9999.ebuild b/app-portage/esearch/esearch-9999.ebuild
index 4bc06cc9d1bb..db0abe567e95 100644
--- a/app-portage/esearch/esearch-9999.ebuild
+++ b/app-portage/esearch/esearch-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="readline(+)"
-DISTUTILS_USE_SETUPTOOLS=no
+DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 git-r3
@@ -19,6 +19,7 @@ IUSE="l10n_fr l10n_it"
KEYWORDS=""
+BDEPEND="${DISTUTILS_DEPS}"
DEPEND="sys-apps/portage"
RDEPEND="${DEPEND}"