summaryrefslogtreecommitdiff
path: root/app-portage/esearch/esearch-1.3-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/esearch/esearch-1.3-r2.ebuild')
-rw-r--r--app-portage/esearch/esearch-1.3-r2.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/app-portage/esearch/esearch-1.3-r2.ebuild b/app-portage/esearch/esearch-1.3-r2.ebuild
deleted file mode 100644
index 3c8b1eac66e5..000000000000
--- a/app-portage/esearch/esearch-1.3-r2.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
-PYTHON_REQ_USE="readline(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Replacement for 'emerge --search' with search-index"
-HOMEPAGE="https://github.com/fuzzyray/esearch"
-SRC_URI="mirror://github/fuzzyray/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="l10n_fr l10n_it"
-
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
-
-DEPEND="
- || (
- sys-apps/portage
- sys-apps/portage-mgorny
- )"
-RDEPEND="${DEPEND}"
-
-# Populate the patches array for any patches for -rX releases
-# It is an array of patch file names of the form:
-# "${FILESDIR}"/${PV}-fix-EPREFIX-capability.patch
-PATCHES=(
- "${FILESDIR}"/${PV}-Fix-setup.py.patch
- "${FILESDIR}"/${PV}-Fix-python-3-compatability.patch
-)
-
-python_prepare_all() {
- python_export_best
- echo VERSION="${PVR}" "${PYTHON}" setup.py set_version
- VERSION="${PVR}" "${PYTHON}" setup.py set_version \
- || die "setup.py set_version failed"
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- dodoc eupdatedb.cron || die "dodoc failed"
-
- # Remove unused man pages according to the l10n flags
- if ! use l10n_fr ; then
- rm -rf "${ED}"/usr/share/man/fr \
- || die "rm failed to remove ${ED}/usr/share/man/fr"
- fi
-
- if ! use l10n_it ; then
- rm -rf "${ED}"/usr/share/man/it \
- || die "rm failed to remove ${ED}/usr/share/man/it"
- fi
-}