summaryrefslogtreecommitdiff
path: root/app-portage/eix
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/eix')
-rw-r--r--app-portage/eix/Manifest2
-rw-r--r--app-portage/eix/eix-0.36.7.ebuild104
2 files changed, 106 insertions, 0 deletions
diff --git a/app-portage/eix/Manifest b/app-portage/eix/Manifest
index bb87d932bfe8..288324baf236 100644
--- a/app-portage/eix/Manifest
+++ b/app-portage/eix/Manifest
@@ -1,3 +1,5 @@
DIST eix-0.36.6.tar.xz 640216 BLAKE2B 40f1d247f6a00ecc9e034f272e73346535724e1b0cf304ea990ae849414adb4490d181db1f781bf7825f18c12cee47e03921a3e43054631d2422e0a6c8a915b8 SHA512 4dbea2a0ac66b15061b491a8da15337894ef4ae18bfb2e77eaf74c6741a45487ca7378c80620341ccf4b335592c121ab55755f0562425a9dbf9a16a9c4aa3554
+DIST eix-0.36.7.tar.xz 639832 BLAKE2B 37202ae78378688ede95b410fe2e6325d63a9553dc082e4e09dc5bcd261f4e7bf49f349a92c286743c30a54cdc5bc1733fedebae33c37d601e6f5db1faf499e7 SHA512 5f5d059b502633be22c8a18fca410e2319061989bbc65b23592c87a9a109b93e615a5b5a7ca92a500999e3cc791e331b12e32a10700cc104040b1980f7f7a0f9
EBUILD eix-0.36.6.ebuild 2495 BLAKE2B c361c7aecf21e5efe8741196dd42df31a917a1c87f5d8afdd8f7f1adb5d81211dc97716b3fb440d264d57f3f5213347de336cbf4f101e0631960929a784063f6 SHA512 556cf4774e86094f27c5dcd24f599097f486694774ab44ec971bdf37313e6d265f6c2dcd42801dab27281c2104f5a08ca2fe0a6f78cdf3698729bb9723b36cd5
+EBUILD eix-0.36.7.ebuild 2503 BLAKE2B a019dfb9386489cb2e04b4825383969846fb09ffc7e93d1d589ebb478559053685980d39be32d71ab5006438d30762e66aff955920acdc1c16178657a07dc3f2 SHA512 73389b23836b97e2eedf62b4c1b8487f68ada03773bde1ef6c860530a09c384cbad67099c80b1abf3adf331aa0c5b8f44120da5dc9b159b3ac5d9a940d22dd17
MISC metadata.xml 952 BLAKE2B ef76318a2bef5560870b4c4e48ca3122ccf67f5951f8cd4a5423b6a667a39311c9725aa99a115d18e0035106f4ebc2d2679987feea91c477d5f19d6244f885cd SHA512 823873a3a87bf0ff3cbb8ab6bd2eebdf45b1f5541aa13cd4a1411def808e03b5c961050a6fc10fa5210694fac9736e0acb4917df75e7d238391dffdbb2094cd9
diff --git a/app-portage/eix/eix-0.36.7.ebuild b/app-portage/eix/eix-0.36.7.ebuild
new file mode 100644
index 000000000000..ca848ab15efe
--- /dev/null
+++ b/app-portage/eix/eix-0.36.7.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools bash-completion-r1 tmpfiles
+
+DESCRIPTION="Search and query ebuilds"
+HOMEPAGE="https://github.com/vaeth/eix/"
+SRC_URI="https://github.com/vaeth/eix/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="debug doc nls sqlite"
+
+DEPEND="
+ nls? ( virtual/libintl )
+ sqlite? ( >=dev-db/sqlite-3:= )"
+RDEPEND="${DEPEND}
+ >=app-shells/push-2.0-r1
+ >=app-shells/quoter-3.0_p2-r1"
+BDEPEND="
+ app-arch/xz-utils
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ # remove stale cache file to prevent collisions
+ local old_cache=${EROOT}/var/cache/${PN}
+ if [[ -f ${old_cache} ]]; then
+ rm "${old_cache}" || die
+ fi
+}
+
+src_prepare() {
+ default
+ sed -i -e "s:/:${EPREFIX}/:" tmpfiles.d/eix.conf || die
+
+ sed -e "/eixf_source=/s:push.sh:cat \"${EPREFIX}/usr/share/push/push.sh\":" \
+ -e "/eixf_source=/s:quoter_pipe.sh:cat \"${EPREFIX}/usr/share/quoter/quoter_pipe.sh\":" \
+ -i src/eix-functions.sh.in || die
+ sed -e "s:'\$(bindir)/eix-functions.sh':cat \\\\\"${EPREFIX}/usr/share/eix/eix-functions\\\\\":" \
+ -i src/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable debug paranoic-asserts)
+ $(use_enable nls)
+ $(use_with doc extra-doc)
+ $(use_with sqlite)
+ --without-protobuf
+
+ # default configuration
+ $(use_with prefix always-accept-keywords)
+ --with-dep-default
+ --with-required-use-default
+
+ # paths
+ --with-portage-rootpath="${ROOTPATH}"
+ --with-eprefix-default="${EPREFIX}"
+
+ # build a single executable with symlinks
+ --disable-separate-binaries
+ --disable-separate-tools
+
+ # used purely to control/disrespect *FLAGS
+ --disable-debugging
+ --disable-new_dialect
+ --disable-optimization
+ --disable-strong-optimization
+ --disable-security
+ --disable-nopie-security
+ --disable-strong-security
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ dobashcomp bash/eix
+ dotmpfiles tmpfiles.d/eix.conf
+
+ rm -r "${ED}"/usr/bin/eix-functions.sh || die
+}
+
+pkg_postinst() {
+ tmpfiles_process eix.conf
+
+ local obs=${EROOT}/var/cache/eix.previous
+ if [[ -f ${obs} ]]; then
+ ewarn "Found obsolete ${obs}, please remove it"
+ fi
+}
+
+pkg_postrm() {
+ if [[ ! -n ${REPLACED_BY_VERSION} ]]; then
+ rm -rf "${EROOT}/var/cache/${PN}" || die
+ fi
+}