summaryrefslogtreecommitdiff
path: root/app-pda/usbmuxd/usbmuxd-1.1.1_pre20200121.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-pda/usbmuxd/usbmuxd-1.1.1_pre20200121.ebuild')
-rw-r--r--app-pda/usbmuxd/usbmuxd-1.1.1_pre20200121.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-pda/usbmuxd/usbmuxd-1.1.1_pre20200121.ebuild b/app-pda/usbmuxd/usbmuxd-1.1.1_pre20200121.ebuild
new file mode 100644
index 000000000000..371f8cb38f28
--- /dev/null
+++ b/app-pda/usbmuxd/usbmuxd-1.1.1_pre20200121.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+COMMIT="8a69f1a78a58476f77b66916091d2405d0cd815f"
+
+inherit autotools systemd udev
+
+DESCRIPTION="USB multiplex daemon for use with Apple iPhone/iPod Touch devices"
+HOMEPAGE="https://www.libimobiledevice.org/"
+SRC_URI="https://cgit.libimobiledevice.org/usbmuxd.git/snapshot/usbmuxd-${COMMIT}.tar.bz2 -> ${P}.tar.bz2"
+
+# src/utils.h is LGPL-2.1+, rest is found in COPYING*
+LICENSE="GPL-2 GPL-3 LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="systemd"
+
+DEPEND="
+ acct-user/usbmux
+ >=app-pda/libimobiledevice-1.2.1_pre0:=
+ >=app-pda/libplist-1.11:=
+ virtual/libusb:1"
+
+RDEPEND="
+ ${DEPEND}
+ virtual/udev
+"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with systemd) \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+ --with-udevrulesdir="$(get_udevdir)"/rules.d
+}