summaryrefslogtreecommitdiff
path: root/app-office
diff options
context:
space:
mode:
Diffstat (limited to 'app-office')
-rw-r--r--app-office/Manifest.gzbin8431 -> 8431 bytes
-rw-r--r--app-office/impressive/Manifest2
-rw-r--r--app-office/impressive/impressive-0.13.2.ebuild46
3 files changed, 48 insertions, 0 deletions
diff --git a/app-office/Manifest.gz b/app-office/Manifest.gz
index d23b46d94b16..c3e20bb1cf47 100644
--- a/app-office/Manifest.gz
+++ b/app-office/Manifest.gz
Binary files differ
diff --git a/app-office/impressive/Manifest b/app-office/impressive/Manifest
index 23c0b1226da9..f92859408fcc 100644
--- a/app-office/impressive/Manifest
+++ b/app-office/impressive/Manifest
@@ -1,3 +1,5 @@
DIST Impressive-0.13.1.tar.gz 215989 BLAKE2B 6591e5fa2c34e7e6f2283b9b6f8cce7485fc8932eea571af96c895bbe23202af195eec0318272667d5656f3aed7a88a21a20397224c7c0cc7c9252364d832371 SHA512 f6221337f9dd79f552fb083e1ea7484aeadec1f8d8e05b4e1b7f6a94037b5026022819b346968dea67dbdb1b646d0571a7aeef26f15c25bee88c5b9c2791cf2b
+DIST Impressive-0.13.2.tar.gz 294531 BLAKE2B 76b50cd1cb1366c9fed7e6f7a16142248f99e232b96b7d7372af181f3ef215aff6f3453d8fd16c2ab6fa0e7217ec831daf3ffafcb8e46ff285dc0b9d86b77839 SHA512 0b24ef39cba25d8813fd3f95f220c466defa50c3ba4a63d2f37b284de2826c2110225fe2016f58c401d1ca239d672ba28ba65069523ab57b1b5711a4222cff92
EBUILD impressive-0.13.1.ebuild 1109 BLAKE2B ef995b3f6fa5cf53d95b66e89820708ca260e24aa75ca77806bac682d4002ea56f552bdb53348b0e46963ec87d946fb04904616bfa15044e396f0d9b48875ecf SHA512 76b3e0f069f056241862c6352f8a7e5f4cca549c41e1802162feff38660c5087754f02e093682690b55c9f86777cac83585ad48e5190540289baf3ae7008daf5
+EBUILD impressive-0.13.2.ebuild 1111 BLAKE2B 56c7c651b688439ca90ff7f5cd12fe81daba04992dcaeebcb5e0192e55560229968663505a83c1046a36b770c30f085718ec22cb64ac7a6a15dbb73db6751a57 SHA512 09ef4a6799482ae6f476cc25f8dfef6633f6e197a4414c29c6dcd31a515fd250fc654fded68d8a2a79ce92c10a55c2c59e4dfaa610ad66521b95d90d225650ca
MISC metadata.xml 334 BLAKE2B 089a7116fcde8065143cfbea3f87f29e676572c8ca9b4e6f2f12c613e7ed58a14fd611b1d55ec8ca3076e2ed852a941dd31b83988440031ad4c338f5b34ed5a2 SHA512 a1b63c4ed0631ff2762219e836519b753840e847cd79423eb14a84b2617fae29b0be16b1dac30c3a8c4589fe1c027c06a2fdff3f7f23909d8b7913b057736623
diff --git a/app-office/impressive/impressive-0.13.2.ebuild b/app-office/impressive/impressive-0.13.2.ebuild
new file mode 100644
index 000000000000..7816aedb6b69
--- /dev/null
+++ b/app-office/impressive/impressive-0.13.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+inherit optfeature python-r1
+
+DESCRIPTION="Stylish way of giving presentations with Python"
+HOMEPAGE="http://impressive.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN^}/${PV/_/-}/${PN^}-${PV/_/-}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ app-text/mupdf
+ dev-python/pygame[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ x11-apps/xrandr
+ || (
+ media-fonts/dejavu
+ media-fonts/corefonts
+ )
+"
+
+DOCS=( changelog.txt demo.pdf )
+HTML_DOCS=( impressive.html )
+
+S="${WORKDIR}/${PN^}-${PV/_/-}"
+
+src_install() {
+ default
+ python_foreach_impl python_doscript ${PN}.py
+ doman impressive.1
+}
+
+pkg_postinst() {
+ optfeature "starting web or e-mail hyperlinks from PDF documents" x11-misc/xdg-utils
+ optfeature "sound and video playback" media-video/ffmpeg
+ optfeature "sound and video playback" media-video/mplayer
+ optfeature "extraction of PDF page titles" app-text/pdftk
+}