summaryrefslogtreecommitdiff
path: root/app-office/unoconv/unoconv-0.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/unoconv/unoconv-0.9.ebuild')
-rw-r--r--app-office/unoconv/unoconv-0.9.ebuild26
1 files changed, 10 insertions, 16 deletions
diff --git a/app-office/unoconv/unoconv-0.9.ebuild b/app-office/unoconv/unoconv-0.9.ebuild
index c4555c5eadd4..53aed7fea67a 100644
--- a/app-office/unoconv/unoconv-0.9.ebuild
+++ b/app-office/unoconv/unoconv-0.9.ebuild
@@ -1,35 +1,30 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit python-single-r1
-inherit eutils python-single-r1
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DESCRIPTION="Convert between document formats supported by Libreoffice"
+DESCRIPTION="Convert between document formats supported by LibreOffice"
HOMEPAGE="http://dag.wiee.rs/home-made/unoconv/"
SRC_URI="https://github.com/dagwieers/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-
KEYWORDS="~amd64 ~x86"
-IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-DEPEND=""
-RDEPEND="${DEPEND}
- ${PYTHON_DEPS}
+RDEPEND="${PYTHON_DEPS}
!app-text/odt2txt
virtual/ooo
"
+PATCHES=( "${FILESDIR}/timeout.patch" )
+
src_prepare() {
- eapply "${FILESDIR}/timeout.patch"
- eapply_user
+ default
python_fix_shebang .
}
@@ -37,6 +32,5 @@ src_compile() { :; }
src_install() {
emake -j1 doc-install install install-links DESTDIR="${D}"
-
- dodoc ChangeLog CHANGELOG.md README.adoc
+ dodoc AUTHORS ChangeLog CHANGELOG.md README.adoc
}