summaryrefslogtreecommitdiff
path: root/app-office/texmacs/texmacs-1.99.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/texmacs/texmacs-1.99.5.ebuild')
-rw-r--r--app-office/texmacs/texmacs-1.99.5.ebuild81
1 files changed, 0 insertions, 81 deletions
diff --git a/app-office/texmacs/texmacs-1.99.5.ebuild b/app-office/texmacs/texmacs-1.99.5.ebuild
deleted file mode 100644
index 879508352d2e..000000000000
--- a/app-office/texmacs/texmacs-1.99.5.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools fdo-mime gnome2-utils qmake-utils
-
-MY_P=${P/tex/TeX}-src
-
-DESCRIPTION="Wysiwyg text processor with high-quality maths"
-HOMEPAGE="http://www.texmacs.org/"
-SRC_URI="ftp://ftp.texmacs.org/pub/TeXmacs/tmftp/source/${MY_P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="imlib jpeg netpbm pdf svg spell"
-KEYWORDS="~alpha ~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- app-text/ghostscript-gpl
- <dev-scheme/guile-1.9[deprecated]
- media-libs/freetype
- x11-apps/xmodmap
- x11-libs/libXext
- virtual/latex-base
- dev-qt/qtgui:4
- imlib? ( media-libs/imlib2 )
- jpeg? ( || ( media-gfx/imagemagick media-gfx/jpeg2ps ) )
- netpbm? ( media-libs/netpbm )
- spell? ( app-text/aspell )
- svg? ( || ( media-gfx/inkscape gnome-base/librsvg:2 ) )
-"
-DEPEND="${RDEPEND}
- x11-base/xorg-proto"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- # respect LDFLAGS, bug #338459
- "${FILESDIR}"/${PN}-plugins-1.patch
-
- # dont update mime and desktop databases and icon cache
- "${FILESDIR}"/${PN}-updates.patch
-
- "${FILESDIR}"/${PN}-1.99.2-desktop.patch
-
- # remove new/delete declarations, bug 590002
- "${FILESDIR}"/${PN}-1.99-remove-new-declaration.patch
-)
-
-src_prepare() {
- default
-
- mv configure.{in,ac} || die
-
- eautoreconf
-
- # delete files that contain binary
- # headers only used on OS X
- rm src/{Plugins/Ghostscript/._ghostscript.cpp,System/Misc/._sys_utils.cpp} || die
-}
-
-src_configure() {
- econf \
- --enable-optimize="${CXXFLAGS}" \
- --with-qt="$(qt4_get_bindir)" \
- $(use_with imlib imlib2) \
- $(use_enable pdf pdf-renderer)
-}
-
-pkg_postinst() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
- gnome2_icon_cache_update
-}