summaryrefslogtreecommitdiff
path: root/app-office/mdbtools/mdbtools-0.7.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/mdbtools/mdbtools-0.7.1-r2.ebuild')
-rw-r--r--app-office/mdbtools/mdbtools-0.7.1-r2.ebuild40
1 files changed, 26 insertions, 14 deletions
diff --git a/app-office/mdbtools/mdbtools-0.7.1-r2.ebuild b/app-office/mdbtools/mdbtools-0.7.1-r2.ebuild
index 63be1d8704b7..ee4183e217e7 100644
--- a/app-office/mdbtools/mdbtools-0.7.1-r2.ebuild
+++ b/app-office/mdbtools/mdbtools-0.7.1-r2.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
-AUTOTOOLS_AUTORECONF=1
-AUTOTOOLS_IN_SOURCE_BUILD=1 # needed for proper man generation
-inherit autotools-utils
+inherit autotools
DESCRIPTION="Set of libraries and utilities for reading Microsoft Access database (MDB) files"
HOMEPAGE="http://mdbtools.sourceforge.net"
@@ -14,30 +12,44 @@ SRC_URI="https://github.com/brianb/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha amd64 ~hppa ~ia64 ppc ppc64 sparc x86"
+IUSE="odbc"
-IUSE="odbc static-libs"
-
-RDEPEND="
- dev-libs/glib:2
- sys-libs/ncurses:0=
- sys-libs/readline:0=
- odbc? ( >=dev-db/unixODBC-2.0 )"
-DEPEND="${RDEPEND}
+BDEPEND="
app-text/txt2man
sys-devel/flex
virtual/pkgconfig
virtual/yacc
"
+RDEPEND="
+ dev-libs/glib:2
+ sys-libs/ncurses:0=
+ sys-libs/readline:0=
+ odbc? ( >=dev-db/unixODBC-2.0 )"
+DEPEND="${RDEPEND}"
DOCS=( AUTHORS ChangeLog HACKING NEWS README TODO )
PATCHES=( "${FILESDIR}/${P}-parallel-make.patch" )
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
src_configure() {
local myeconfargs=(
--disable-gtk-doc
--disable-gmdb2
+ --disable-static
$(use odbc && echo "--with-unixodbc=${EPREFIX}/usr")
)
- autotools-utils_src_configure
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
}