summaryrefslogtreecommitdiff
path: root/app-office/libreoffice/libreoffice-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/libreoffice/libreoffice-9999.ebuild')
-rw-r--r--app-office/libreoffice/libreoffice-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/app-office/libreoffice/libreoffice-9999.ebuild b/app-office/libreoffice/libreoffice-9999.ebuild
index 7eec09df7595..3341480b61da 100644
--- a/app-office/libreoffice/libreoffice-9999.ebuild
+++ b/app-office/libreoffice/libreoffice-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -395,6 +395,9 @@ src_configure() {
einfo "Preset CFLAGS: ${CFLAGS}"
einfo "Preset LDFLAGS: ${LDFLAGS}"
+ # Workaround for bug #915067
+ append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
+
if use clang ; then
# Force clang
einfo "Enforcing the use of clang due to USE=clang ..."
@@ -408,9 +411,6 @@ src_configure() {
# Workaround for bug #907905
filter-lto
- # Workaround for bug #915067
- append-ldflags -Wl,--undefined-version
-
# Not implemented by Clang, bug #903889
filter-flags -Wlto-type-mismatch -Werror=lto-type-mismatch
else