summaryrefslogtreecommitdiff
path: root/app-office/libreoffice/libreoffice-7.0.3.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/libreoffice/libreoffice-7.0.3.1.ebuild')
-rw-r--r--app-office/libreoffice/libreoffice-7.0.3.1.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/app-office/libreoffice/libreoffice-7.0.3.1.ebuild b/app-office/libreoffice/libreoffice-7.0.3.1.ebuild
index 753ef4fb54d4..2d3f699e1f94 100644
--- a/app-office/libreoffice/libreoffice-7.0.3.1.ebuild
+++ b/app-office/libreoffice/libreoffice-7.0.3.1.ebuild
@@ -21,7 +21,7 @@ BRANDING="${PN}-branding-gentoo-0.8.tar.xz"
# PATCHSET="${P}-patchset-01.tar.xz"
[[ ${MY_PV} == *9999* ]] && inherit git-r3
-inherit autotools bash-completion-r1 check-reqs flag-o-matic java-pkg-opt-2 multiprocessing python-single-r1 qmake-utils toolchain-funcs xdg-utils
+inherit autotools bash-completion-r1 check-reqs eapi8-dosym flag-o-matic java-pkg-opt-2 multiprocessing python-single-r1 qmake-utils toolchain-funcs xdg-utils
DESCRIPTION="A full office productivity suite"
HOMEPAGE="https://www.libreoffice.org"
@@ -418,7 +418,6 @@ src_configure() {
if use custom-cflags ; then
elog "USE=custom-cflags has been selected. You are on your own to make sure that"
elog "the build succeeds. Good luck!"
- strip-unsupported-flags
else
strip-flags
fi
@@ -637,12 +636,12 @@ EOF
python_optimize "${D}"${lodir}/program
# link python bridge in site-packages, bug 667802
- local py pyc loprogdir=$(get_libdir)/libreoffice/program
+ local py pyc loprogdir=/usr/$(get_libdir)/libreoffice/program
for py in uno.py unohelper.py officehelper.py; do
- dosym ../../../${loprogdir}/${py} $(python_get_sitedir)/${py}
+ dosym8 -r ${loprogdir}/${py} $(python_get_sitedir)/${py}
while IFS="" read -d $'\0' -r pyc; do
pyc=${pyc//*\/}
- dosym ../../../../${loprogdir}/__pycache__/${pyc} $(python_get_sitedir)/__pycache__/${pyc}
+ dosym8 -r ${loprogdir}/__pycache__/${pyc} $(python_get_sitedir)/__pycache__/${pyc}
done < <(find "${D}"${lodir}/program -type f -name ${py/.py/*.pyc} -print0)
done