summaryrefslogtreecommitdiff
path: root/app-office/libreoffice/libreoffice-6.4.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/libreoffice/libreoffice-6.4.9999.ebuild')
-rw-r--r--app-office/libreoffice/libreoffice-6.4.9999.ebuild30
1 files changed, 23 insertions, 7 deletions
diff --git a/app-office/libreoffice/libreoffice-6.4.9999.ebuild b/app-office/libreoffice/libreoffice-6.4.9999.ebuild
index e42e510981a9..727d2c010c58 100644
--- a/app-office/libreoffice/libreoffice-6.4.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-6.4.9999.ebuild
@@ -46,6 +46,20 @@ unset DEV_URI
ADDONS_SRC=(
# QR code generating library for >=libreoffice-6.4
"${ADDONS_URI}/QR-Code-generator-1.4.0.tar.gz"
+ "base? (
+ ${ADDONS_URI}/commons-logging-1.2-src.tar.gz
+ ${ADDONS_URI}/ba2930200c9f019c2d93a8c88c651a0f-flow-engine-0.9.4.zip
+ ${ADDONS_URI}/d8bd5eed178db6e2b18eeed243f85aa8-flute-1.1.6.zip
+ ${ADDONS_URI}/eeb2c7ddf0d302fba4bfc6e97eac9624-libbase-1.1.6.zip
+ ${ADDONS_URI}/3bdf40c0d199af31923e900d082ca2dd-libfonts-1.1.6.zip
+ ${ADDONS_URI}/3404ab6b1792ae5f16bbd603bd1e1d03-libformula-1.1.7.zip
+ ${ADDONS_URI}/db60e4fde8dd6d6807523deb71ee34dc-liblayout-0.2.10.zip
+ ${ADDONS_URI}/97b2d4dba862397f446b217e2b623e71-libloader-1.1.6.zip
+ ${ADDONS_URI}/8ce2fcd72becf06c41f7201d15373ed9-librepository-1.1.6.zip
+ ${ADDONS_URI}/f94d9870737518e3b597f9265f4e9803-libserializer-1.1.6.zip
+ ${ADDONS_URI}/ace6ab49184e329db254e454a010f56d-libxml-1.1.7.zip
+ ${ADDONS_URI}/39bb3fcea1514f1369fcfc87542390fd-sacjava-1.3.zip
+ )"
"java? ( ${ADDONS_URI}/17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip )"
# no release for 8 years, should we package it?
"libreoffice_extensions_wiki-publisher? ( ${ADDONS_URI}/a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip )"
@@ -64,11 +78,12 @@ unset ADDONS_SRC
# Extensions that need extra work:
LO_EXTS="nlpsolver scripting-beanshell scripting-javascript wiki-publisher"
-IUSE="accessibility bluetooth +branding coinmp +cups +dbus debug eds firebird
+IUSE="accessibility base bluetooth +branding coinmp +cups +dbus debug eds firebird
googledrive gstreamer +gtk kde ldap +mariadb odk pdfimport postgres test
$(printf 'libreoffice_extensions_%s ' ${LO_EXTS})"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ base? ( firebird java )
bluetooth? ( dbus )
gtk? ( dbus )
libreoffice_extensions_nlpsolver? ( java )
@@ -268,11 +283,10 @@ _check_reqs() {
}
pkg_pretend() {
- if ! use java && ! use firebird; then
- ewarn "If you plan to use Base application you must enable either firebird or java."
- fi
-
- use java || ewarn "Without java, several wizards are not going to be available."
+ use base ||
+ ewarn "If you plan to use Base application you must enable USE base."
+ use java ||
+ ewarn "Without USE java, several wizards are not going to be available."
[[ ${MERGE_TYPE} != binary ]] && _check_reqs pkg_pretend
}
@@ -409,7 +423,6 @@ src_configure() {
--disable-online-update
--disable-openssl
--disable-pdfium
- --disable-report-builder
--disable-vlc
--with-build-version="${gentoo_buildid}"
--enable-extension-integration
@@ -428,8 +441,11 @@ src_configure() {
--with-help="html"
--without-helppack-integration
--with-system-gpgmepp
+ --without-system-jfreereport
+ --without-system_apache_commons
--without-system-sane
--without-system-qrcodegen
+ $(use_enable base report-builder)
$(use_enable bluetooth sdremote-bluetooth)
$(use_enable coinmp)
$(use_enable cups)