summaryrefslogtreecommitdiff
path: root/app-office/libreoffice/libreoffice-6.2.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/libreoffice/libreoffice-6.2.9999.ebuild')
-rw-r--r--app-office/libreoffice/libreoffice-6.2.9999.ebuild65
1 files changed, 33 insertions, 32 deletions
diff --git a/app-office/libreoffice/libreoffice-6.2.9999.ebuild b/app-office/libreoffice/libreoffice-6.2.9999.ebuild
index 4b4ea02af443..caf354cdab3b 100644
--- a/app-office/libreoffice/libreoffice-6.2.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-6.2.9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
PYTHON_REQ_USE="threads(+),xml"
@@ -21,7 +21,7 @@ BRANDING="${PN}-branding-gentoo-0.8.tar.xz"
PATCHSET="${PN}-6.2.1.1-patchset-01.tar.xz"
[[ ${MY_PV} == *9999* ]] && inherit git-r3
-inherit autotools bash-completion-r1 check-reqs eapi7-ver flag-o-matic java-pkg-opt-2 multiprocessing pax-utils python-single-r1 qmake-utils toolchain-funcs xdg
+inherit autotools bash-completion-r1 check-reqs flag-o-matic java-pkg-opt-2 multiprocessing pax-utils python-single-r1 qmake-utils toolchain-funcs xdg
DESCRIPTION="A full office productivity suite"
HOMEPAGE="https://www.libreoffice.org"
@@ -79,6 +79,14 @@ SLOT="0"
[[ ${MY_PV} == *9999* ]] || \
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/bison
+ sys-devel/flex
+ sys-devel/gettext
+ virtual/pkgconfig
+ odk? ( >=app-doc/doxygen-1.8.4 )
+"
COMMON_DEPEND="${PYTHON_DEPS}
app-arch/unzip
app-arch/zip
@@ -192,26 +200,6 @@ COMMON_DEPEND="${PYTHON_DEPS}
pdfimport? ( app-text/poppler:=[cxx] )
postgres? ( >=dev-db/postgresql-9.0:*[kerberos] )
"
-
-RDEPEND="${COMMON_DEPEND}
- !app-office/libreoffice-bin
- !app-office/libreoffice-bin-debug
- !app-office/openoffice
- media-fonts/liberation-fonts
- || ( x11-misc/xdg-utils kde-plasma/kde-cli-tools )
- java? ( >=virtual/jre-1.6 )
- kde? ( kde-frameworks/breeze-icons:* )
- vlc? ( media-video/vlc )
-"
-
-if [[ ${MY_PV} != *9999* ]] && [[ ${PV} != *_* ]]; then
- PDEPEND="=app-office/libreoffice-l10n-$(ver_cut 1-2)*"
-else
- # Translations are not reliable on live ebuilds
- # rather force people to use english only.
- PDEPEND="!app-office/libreoffice-l10n"
-fi
-
# FIXME: cppunit should be moved to test conditional
# after everything upstream is under gbuild
# as dmake execute tests right away
@@ -221,14 +209,9 @@ DEPEND="${COMMON_DEPEND}
dev-perl/Archive-Zip
>=dev-util/cppunit-1.14.0
>=dev-util/gperf-3
- dev-util/intltool
>=dev-util/mdds-1.4.1:1=
media-libs/glm
- sys-devel/bison
- sys-devel/flex
- sys-devel/gettext
sys-devel/ucpp
- virtual/pkgconfig
x11-base/xorg-proto
x11-libs/libXt
x11-libs/libXtst
@@ -236,7 +219,6 @@ DEPEND="${COMMON_DEPEND}
dev-java/ant-core
>=virtual/jdk-1.6
)
- odk? ( >=app-doc/doxygen-1.8.4 )
test? (
app-crypt/gnupg
dev-util/cppunit
@@ -244,11 +226,30 @@ DEPEND="${COMMON_DEPEND}
media-fonts/liberation-fonts
)
"
+RDEPEND="${COMMON_DEPEND}
+ !app-office/libreoffice-bin
+ !app-office/libreoffice-bin-debug
+ !app-office/openoffice
+ media-fonts/liberation-fonts
+ || ( x11-misc/xdg-utils kde-plasma/kde-cli-tools )
+ java? ( >=virtual/jre-1.6 )
+ kde? ( kde-frameworks/breeze-icons:* )
+ vlc? ( media-video/vlc )
+"
+if [[ ${MY_PV} != *9999* ]] && [[ ${PV} != *_* ]]; then
+ PDEPEND="=app-office/libreoffice-l10n-$(ver_cut 1-2)*"
+else
+ # Translations are not reliable on live ebuilds
+ # rather force people to use english only.
+ PDEPEND="!app-office/libreoffice-l10n"
+fi
PATCHES=(
# master branch
"${FILESDIR}/${PN}-6.2-ldap-optional.patch"
- "${WORKDIR}"/${PATCHSET/.tar.xz/}
+ "${WORKDIR}"/${PATCHSET/.tar.xz/}/001-qt5-change-salgraphics-gettextlayout-def.patch
+ "${WORKDIR}"/${PATCHSET/.tar.xz/}/002-qt5-assert-missing-salgraphics-font-on-gettextlayout.patch
+ "${WORKDIR}"/${PATCHSET/.tar.xz/}/003-qt5-fpicker-honor-autoextension.patch
# not upstreamable stuff
"${FILESDIR}/${PN}-5.4-system-pyuno.patch"
@@ -554,7 +555,7 @@ src_install() {
insinto /usr/$(get_libdir)/${PN}/program
newins "${WORKDIR}/branding-sofficerc" sofficerc
dodir /etc/env.d
- echo "CONFIG_PROTECT=/usr/$(get_libdir)/${PN}/program/sofficerc" > "${ED%/}"/etc/env.d/99${PN} || die
+ echo "CONFIG_PROTECT=/usr/$(get_libdir)/${PN}/program/sofficerc" > "${ED}"/etc/env.d/99${PN} || die
fi
# Hack for offlinehelp, this needs fixing upstream at some point.
@@ -563,8 +564,8 @@ src_install() {
insinto /usr/$(get_libdir)/libreoffice/help
doins xmlhelp/util/*.xsl
- pax-mark -m "${ED%/}"/usr/$(get_libdir)/libreoffice/program/soffice.bin
- pax-mark -m "${ED%/}"/usr/$(get_libdir)/libreoffice/program/unopkg.bin
+ pax-mark -m "${ED}"/usr/$(get_libdir)/libreoffice/program/soffice.bin
+ pax-mark -m "${ED}"/usr/$(get_libdir)/libreoffice/program/unopkg.bin
}
pkg_preinst() {