summaryrefslogtreecommitdiff
path: root/app-office/dia2code/dia2code-1.0.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/dia2code/dia2code-1.0.0-r1.ebuild')
-rw-r--r--app-office/dia2code/dia2code-1.0.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-office/dia2code/dia2code-1.0.0-r1.ebuild b/app-office/dia2code/dia2code-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..58e26fc2f4bd
--- /dev/null
+++ b/app-office/dia2code/dia2code-1.0.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2
+
+DESCRIPTION="Convert UML diagrams produced with Dia to various source code flavours"
+HOMEPAGE="http://dia2code.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ test? ( app-shells/bash )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-imports.patch
+)
+
+src_prepare() {
+ # Script makes use of arrays
+ sed -e 's:/bin/sh:/bin/bash:' -i tests/tests.sh || die
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+ doman docs/dia2code.1
+}