summaryrefslogtreecommitdiff
path: root/app-office/dia/files/dia-0.97.0-gnome-doc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/dia/files/dia-0.97.0-gnome-doc.patch')
-rw-r--r--app-office/dia/files/dia-0.97.0-gnome-doc.patch61
1 files changed, 61 insertions, 0 deletions
diff --git a/app-office/dia/files/dia-0.97.0-gnome-doc.patch b/app-office/dia/files/dia-0.97.0-gnome-doc.patch
new file mode 100644
index 000000000000..63e13deaf22f
--- /dev/null
+++ b/app-office/dia/files/dia-0.97.0-gnome-doc.patch
@@ -0,0 +1,61 @@
+From 9d40692b695b30f80b263814bdd351c0dbe67733 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Mon, 18 May 2009 22:19:35 +0200
+Subject: [PATCH] Fix compilation in a gnome environment, gentoo bug #159831
+
+---
+ configure.in | 19 +++++++++++--------
+ 1 files changed, 11 insertions(+), 8 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index d27ee6e..d9c0bf4 100644
+--- a/configure.in
++++ b/configure.in
+@@ -110,17 +110,19 @@ if test "$have_libart" = "yes" ; then
+ fi
+
+ AC_MSG_CHECKING([whether GNOME specific code should be used])
+-AC_ARG_ENABLE(gnome,[ --enable-gnome enable gnome code],
+- GNOME=$enableval, GNOME=no)
+-if test "$GNOME" = "yes" ; then
++AC_ARG_ENABLE(gnome,
++ AC_HELP_STRING([--enable-gnome],[enable gnome code]),,
++ enable_gnome=no)
++if test "x$enable_gnome" = "xyes" ; then
+ GTK_MODULES="$GTK_MODULES libgnome-2.0 libgnomeui-2.0"
+ AC_DEFINE(GNOME,1,[Define if building with GNOME support])
++ AC_DEFINE(HAVE_GNOME,1,[Define if building with GNOME support])
+ AC_DEFINE_UNQUOTED(GNOME_ICONDIR, "${prefix}/share/pixmaps", [GNOME icon directory])
+- have_gnome=true
++ have_gnome=yes
+ else
+- have_gnome=false
++ have_gnome=no
+ fi
+-AM_CONDITIONAL(HAVE_GNOME, $have_gnome)
++AM_CONDITIONAL(HAVE_GNOME, [test "x$have_gnome" != "xno"])
+ AC_MSG_RESULT($GNOME)
+
+ dnl GTK2: libgnomecanvas-2.0 ?
+@@ -129,7 +131,8 @@ PKG_CHECK_MODULES(GTK,$GTK_MODULES)
+ AC_SUBST(GTK_CFLAGS)
+ AC_SUBST(GTK_LIBS)
+
+-AM_CONDITIONAL(HAVE_BONOBO,false)
++#AM_CONDITIONAL(HAVE_BONOBO,false)
++AM_CONDITIONAL(HAVE_BONOBO,[test "true" = "false"])
+
+ dnl Look for Cairo
+ AC_ARG_WITH(cairo,
+@@ -627,7 +630,7 @@ Configuration:
+ Source code location: ${srcdir}
+ Compiler: ${CC}
+
+- Gnome support: ${GNOME}
++ Gnome support: ${have_gnome}
+ Python support: ${with_python}
+ Libart support (PNG export): ${have_libart}
+ Cairo support (PNG, PDF, print): ${with_cairo}
+--
+1.6.3
+